Showing results for 
Search instead for 
Did you mean: 

Unable to change SSH port number from port 22 on ICX switches

RUCKUS Team Member

Error encountered below:

ICX8200-24 Router(config)#ip ssh port 2300
Close all current SSH connections, then try again

From Debugs we see below details : 

[U1][3][Apr  4 19:15:00.018][sshm][Debug][11916806089001951530] SSH_SUCC[12]: Outgoing_Connection_ESTABLISHED
[U1][3][Apr  4 19:15:00.018][sshm][Debug][11916806089001951530] SSH[12]: session state: Init 

[U1][3][Apr  4 19:20:00.017][sshm][Debug][11916806089001951530] SSH_SUCC[11]: Outgoing_Connection_ESTABLISHED
[U1][3][Apr  4 19:20:00.017][sshm][Debug][11916806089001951530] SSH[11]: session state: Init 
[U1][3][Apr  4 19:20:00.640][sshm][Debug][1155957247621203457] SSH[10]: RX Message TYPE[SSH_MSG_CHANNEL_OPEN], PKT_LEN[92], PAYLOAD_LEN[71]
[U1][3][Apr  4 19:20:00.702][sshm][Debug][11916806089001951530] SSH_SUCC[12]: Outgoing_Connection_ESTABLISHED
[U1][3][Apr  4 19:20:00.703][sshm][Debug][11916806089001951530] SSH[12]: session state: Init 
[U1][3][Apr  4 19:20:16.598][sshm][Debug][1155975265009010177] SSH[10]: RX Message TYPE[SSH_MSG_CHANNEL_WINDOW_ADJUST], PKT_LEN[28], PAYLOAD_LEN[8]

The above SSH debugs show us that this occurs when the switch is connected to Smartzone.

From Lab test:

From Logs:

manager active-list
manager registrar
manager port-list 987

Config Status:Enabled Operation Status:Enabled

SWR List : None
DNS List :
Active List :
Active List IPV6 : None
DHCP Option 43 : No
DHCP Opt 43 List : None
Backup List : None
Backup List IPV6 : None
Merged List :

SZ IP Used :
Port List : 987
Server Port Used : 443
SWR host :
SWR discovery retry cnt : 0
SWR host retry time : 15
Query Status : APPROVED

SSH Tunnel Status -:
Tunnel Status : Established
SSH Port : 22
CLI IP/Port :
SNMP IP/Port :
Syslog IP/Port :
Timer Status : Not Running

After Removing SZ config:

ICX8200-24 Router(config)#

ICX8200-24 Router(config)#no manager active-list
ICX8200-24 Router(config)#
ICX8200-24 Router(config)#
ICX8200-24 Router(config)#
ICX8200-24 Router(config)#show sz status

============    MGMT Agent State Info     ===================

Config Status:Enabled Operation Status:Disabled
State:DISABLED  Prev State:QUERY        Event:SZ_EVENT_NONE

SWR List                : None
DNS List                :
Active List             : None
Active List IPV6        : None
DHCP Option 43          : No
DHCP Opt 43 List        : None
Backup List             : None
Backup List IPV6        : None
Merged List             :

SZ IP Used              :
Port List               : 987
Server Port Used        : 443
SWR host                :
SWR discovery retry cnt : 0
SWR host retry time     : 15
Query Status            : Not Initiated

SSH Tunnel Status -:
Tunnel Status           : Not Initiated
SSH Port                : 22
CLI IP/Port             : None/None
SNMP IP/Port            : None/None
Syslog IP/Port          : None/None
HTTP CLIENT IP/Port     : None/None
HTTP SERVER IP/Port     : None/None
Timer Status            : Not Running

ICX8200-24 Router(config)#ip ssh port 2300
ICX8200-24 Router(config)#


  • Remove active list using command " no manager active-list <ip address> "
  • Check "show sz status" and make sure sz is disconnected 
  • Run "ip ssh port 2300" and enter 
  • Enable the sz connection once port number is changed 

Other solutions:

  • Run “manager disable”. This will bring the ssh connection down and switch will be down in SmartZone and state in the "Show sz status " will be disabled
  • Even when switch is not connected to Smartzone you will be able to change the SSH port number in the switch