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iOS mobile app unable to login to manage Unleashed network.

sanjay_kumar
RUCKUS Team Member

Issue:
When iOS mobile users tries to login to Unleashed app using the admin credentials, the authentication gets failed with the error "You are not connected to Unleashed Network.  Go to Settings"
This issue is affected for iOS devices only, Android app works fine.

sanjay_kumar_0-1692729203344.png

Root Cause:
The issue is due to the Security DNS introduced in the IOS. The new IOS versions support security DNS, but our AP's dnsspoof can work for our fixed domain Unleashed.ruckuswireless.com.  When mobile App use this domain to access the master AP, it fails.

Fix:
The issue is addressed in the latest Unleashed version 200.14.6.1.199 and with the new iOS mo
https://support.ruckuswireless.com/software/3780-ruckus-unleashed-ap-200-7-mr-refresh8-software-for-...
bile app.
You need to upgrade the AP and the IOS app to resolve the issue.

We have also released a 200.7 MR version to fix the issue on older AP models.
Ruckus Unleashed AP 200.7 (MR Refresh8) : 200.7.10.202.145
Check out the release notes for the AP models supported.
https://support.ruckuswireless.com/software/3780-ruckus-unleashed-ap-200-7-mr-refresh8-software-for-...

Since the mobile app is not working in order to upgrade the AP, you can use the below options to access the AP.
1. Open the browser and access the AP's IP address >> enter the admin credentials >> Upgrade the AP firmware to 200.14.6.1.199
2. Use a PC to access the AP.

Below is the complete steps for accessing the AP from PC:

  1. Please connect your laptop/PC to the Unleashed SSID Or to the LAN network where the AP is connected.
  2. If you are connecting to LAN, Make sure the Laptop has same IP range as AP’s.
  3. Open browser and enter address https://unleashed.ruckuswireless.com Or use AP’s IP address.
  4. Login with your Unleashed username and password.
    sanjay_kumar_4-1692730114961.png

     

  5. Once successfully logged in go to Admin & Services -> Administration >> Upgrade >> Select the firmware version 200.14.6.1.199 and upgrade.
    Or, you can also use “Local Upgrade” option if you have the 200.14.6.1.199 firmware downloaded from the support site.

     
    sanjay_kumar_3-1692730086943.png

Regards,
Sanjay Kumar

17 REPLIES 17

eric_hutchens
New Contributor III

I am a Lennar user, currently running 200.7 firmware on my R510 AP s. I tried to follow the instructions here for upgrading firmware to 200.14, but when logging into the Master AP through my desktop web browser (Admin & Services > Administration > Upgrade), it wont initiate the search for firmware upgrades --- everything just sits there, greyed-out.  I tried doing a manual login through the Unleashed app (iOS), and doing the firmware upgrade that way, but the screen I end up at recommends that I update to 200.14  but it lists 200.9 (three times!) as the only option available!  Can I update my R510 APs to 200.14?

sanjay_kumar
RUCKUS Team Member

Hi @eric_hutchens 
Can you download the below software for R510 and do the upgrade using "Local Upgrade" option? Please do this via PC.
https://support.ruckuswireless.com/software/3672-ruckus-unleashed-ap-200-14-ga-refresh-software-for-...

eric_hutchens
New Contributor III

I will try this.  I have 2 R510s in my house (Master/Member) --- do I just do the upgrades one at a time, or is there anything special I need to do since I have two of them to worry about?

Hi @eric_hutchens 
If both the R510s are connected as Master-Member, you just need to login to the Master and do the upgrade, it will do the upgrade for the rest of the connected APs.