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iOS mobile app unable to login to manage Unleashed network.

sanjay_kumar
RUCKUS Team Member

Issue:
When iOS mobile users tries to login to Unleashed app using the admin credentials, the authentication gets failed with the error "You are not connected to Unleashed Network.  Go to Settings"
This issue is affected for iOS devices only, Android app works fine.

sanjay_kumar_0-1692729203344.png

Root Cause:
The issue is due to the Security DNS introduced in the IOS. The new IOS versions support security DNS, but our AP's dnsspoof can work for our fixed domain Unleashed.ruckuswireless.com.  When mobile App use this domain to access the master AP, it fails.

Fix:
The issue is addressed in the latest Unleashed version 200.14.6.1.199 and with the new iOS mo
https://support.ruckuswireless.com/software/3780-ruckus-unleashed-ap-200-7-mr-refresh8-software-for-...
bile app.
You need to upgrade the AP and the IOS app to resolve the issue.

We have also released a 200.7 MR version to fix the issue on older AP models.
Ruckus Unleashed AP 200.7 (MR Refresh8) : 200.7.10.202.145
Check out the release notes for the AP models supported.
https://support.ruckuswireless.com/software/3780-ruckus-unleashed-ap-200-7-mr-refresh8-software-for-...

Since the mobile app is not working in order to upgrade the AP, you can use the below options to access the AP.
1. Open the browser and access the AP's IP address >> enter the admin credentials >> Upgrade the AP firmware to 200.14.6.1.199
2. Use a PC to access the AP.

Below is the complete steps for accessing the AP from PC:

  1. Please connect your laptop/PC to the Unleashed SSID Or to the LAN network where the AP is connected.
  2. If you are connecting to LAN, Make sure the Laptop has same IP range as AP’s.
  3. Open browser and enter address https://unleashed.ruckuswireless.com Or use AP’s IP address.
  4. Login with your Unleashed username and password.
    sanjay_kumar_4-1692730114961.png

     

  5. Once successfully logged in go to Admin & Services -> Administration >> Upgrade >> Select the firmware version 200.14.6.1.199 and upgrade.
    Or, you can also use “Local Upgrade” option if you have the 200.14.6.1.199 firmware downloaded from the support site.

     
    sanjay_kumar_3-1692730086943.png

Regards,
Sanjay Kumar

17 REPLIES 17

GregR
New Contributor II

Hello,

I tried option 2, connecting my PC to the Master AP. I have connected my laptop to the Ruckus network SSID. When I open a Firefox or Chrome Browser window and try to go to https://unleashed.ruckuswireless.com/ I get warnings from both browsers that this site is not secure and am cautioned not to go to this site. Can/should I go to this address regardless of these warnings?

Also, I earlier tried option 1 when this issue was first described in June. I used one of the public tools (Advanced IP Scanner) to try to find the Master AP's IP address but it was confusing.I get the following Ruckus named devices:

1 - Name 192.168.1.125/ IP Address 192.168.1.125/ Manufacturer Ruckus Wireless/ MAC Address 90:3A:72:1A:0E:00

2 - Name Greggo.lan/ IP Address 192.168.1.191/ Manufacturer Ruckus Wireless/ MAC Address 90:3A:72:19:5F:60

Which of the above two is the Master AP's IP address?

I also get the Switch information: Name ICX7150-C12-Switch.lan/ IP Address 192.168.1.33/ Manufacturer Brocade Communications Systems LLC/ MAC Address 60:9C:9F:E6:87:D2

How should I proceed with either option 1 or 2 in light of the above?

GregR

sanjay_kumar
RUCKUS Team Member

Hi @GregR 
In Option 2, you can ignore the warning and proceed to access the URL, as the SSL cert loaded is a default certificate so that warning.

With the option 1, I guess you have 2 APs connected to the Unleashed network, if you are not aware of the Master's IP, then you can access both IP address, only Master IP will give you the GUI.

GregR
New Contributor II

Hello,

I proceeded with option 2 and used the https://unleashed.ruckuswireless.com/ link to access my Ruckus network. My Master AP was clearly labeled. I went to the admin option, downloaded the latest firmware from the Ruckus website and waited for the install to complete. I now have access to my Ruckus network through the Unleashed app.

I have two follow up questions.

1. When I now open the unleashed app I am getting a message that there is a newer app version available for download but the version I have installed on my iPhone is the latest version of the app. Why is this app version upgrade notification appearing?

2. When I am in the Unleashed app I can clearly see my two APs and the clients connected to them, however I see no switch. I have a Ruckus ICX 7150-C12P switch. Why is it not showing up as a switch in the Unleashed app?

sanjay_kumar
RUCKUS Team Member

Hi @GregR 
For the 1st question, can you check the version which is already installed? It should be 11.138.1, this has the fix for the iOS mobile app with regards to security DNS issue.
We have released a latest mobile app which is 11.140.1 which has update on the Facebook issue.

For the question 2, is this a Lennar home setup? If not can you open a support case so that we can check on this?

For the second 

jwaldeck
New Contributor

I'm having this issue on my iPhone. I hadn't tried accessing the app for a while but was having some wifi issues last night and tried to log in, but I get the error that I'm not connected to an unleashed network. The app version is 11.140.1 and I upgraded my access points through my laptop at unleashed.ruckus.com to 200.14.6.1.203, but the issue is still occuring. 

Edit: Nevermind, I'm an idiot, my phone never reconnected to my network after the upgrade, I hadn't noticed that. After connecting manually to my network, it's working fine now.