Showing results for 
Search instead for 
Did you mean: 

RUCKUS ICX 7150-C12P stopped working, no status LEDs on, SYST led is amber, all PoE are off

New Contributor II


 I have RUCKUS ICX 7150-C12P setup in my Lennar home when brought the house in 2020. And it's been working fine until few weeks ago. When I checked, all the PoE lights are off, none of the status LEDs are on, and SYST light is amber. I restarted and nothing changed. Current, none of the IOTs are working due to this.

I have not done anything since it was setup in Jan 2020. Looking for guidance on how do I go about troubleshooting this, if there are particular sequence I should follow or directly factory reset or somethings else. I am not geek in networking but i do consider myself a handyman generally speaking and could try with some guidance.

Thank you and much appreciate any help.




Hi @anandbellad 

Basically, due the power outage / spike of power /  the switch went to a state that we called (boot-mode) that is not able to boot up properly. 

That does not mean is broken or need to be replace 'in some cases'

1-Please try to disconnect from the Power outlet the ICX-7150 and reconnected.

2-Please try to press the reset button using a paper click or a small stick 

  1. Remove power from the switch.
  2. Press and hold the Reset button while applying power to the switch.
  3. After all the system LEDs flash amber, release the Reset button.

Video link:

If that does not make any difference, we need to perform a software recovery since it can be that the image flash is corrupted so in basic words the unit is not able to boot up properly and need re-install the image to boot up properly.

3-We need to access (physical) using one of the cables to the ICX-7150C12P mentioned on the below guide: 

How to console in the ICX-7150-12cp

Once we are there, we can try to boot up the unit using the following commands: 

Boot_primary or Boot_secondary 

If that step does not work Software recovery needs to be applied

Here is the guide:

 Video Link:

Best Regards 

Fernando Vasquez 

View solution in original post

New Contributor II

Not everyone.

also I checked different articles and see the visitors claims about the uploading photos.

I replied with the error message.

View solution in original post


Tried boot by connecting console but i keep getting error as Kernal file corrupt or not available(both primary and secondary). Then I moved on to Recovery steps, I am having issue with TFTP server connection, i have downloaded the files and setup TFTP and console but some how ping test is failing for TFTP server. I will continue to troubleshoot this.

Meanwhile, for ICX 7150 is there an option to boot and upgrade from USB drive, I am just struggling with TFTP server. 



Hi @anandbellad 

When the Switch is on boot mode the only way to recover is via TFTP server.

Please sent us a screenshot with the error : 

upload photo.png

Maybe  Windows Firewall is blocking the ping you can disable it to by pass this. 

Best Regards 

Fernando Vasquez

Hi Fernando, 

 Apparently my RF45 cable was malfunctioning. I ordered and got the new one from Amazon and it was smooth recovery. Everything is back to life and working as it was before. Truly appreciate your responses and support/guidance(world is better place with folks like you). Thank you !

Hi @anandbellad 

Great to hear that !!! 

More than happy to assist you on this ! 

I highly recommend you  to move the switch to the recommended version base on the support site ( 8095g ) to avoid this problem or issue in the future.


There are 3 different methods to upgrade the switch

1-How to upgrade a Switch ICX7150-C12P via TFTP

Video Link as reference:

2-How to perform an Upgrade via Web GUI (ICX7150 Switch)

1-How to Upgrade a Switch ICX-7150-C12P using a USB flash drive

Feel free to mark the post as solved 

Best Regards 

Fernando Vasquez 

Hi @anandbellad


You can even copy and paste in the post as well.


Best regards,

Yarenis Hernández.

Technical Support Engineer | L2 TAC Wired | Lennar Home Community