Showing results for 
Search instead for 
Did you mean: 

Ruckus icx7150 switch - dropping connection

New Contributor

I have what appears to be the switch/router issue.  I need assistance accessing CLI to run the 4 commands.  I can log into dashboard of my switch and i can see the disconnected issue.  I identified the IP address and used Putty to login.  But the command prompt is ruckus>   not the expected icx7150 switch>  The commands do not work with exception of enable which changes prompt from ruckus> to ruckus#   I found a list of commands by typing help, but none of they listed commands to correct issue exist.   I typed in sysInfo and it appears as though this is the then i am confused.  Did i log into an AP instead of switch?  So i checked MAC address of swtich and went back to IP scanner and confirmed IP address again.  

All the information i see tells me the IP address matches the switch, but even when i log into dashboard, it identifies the Master AP?? as having the same IP address as what I assumed the switch has.  I just need to get past this hurdle to enter the codes in.  Any suggestions?


RUCKUS Team Member

Hi Myles, 

The prompt for the ICX normally appears like this: "7150-switch or ICX-7150, etc" if you enter the CLI and get this instead: ruckus> to ruckus# you are probably in the AP and not the ICX switch, if I enter "help" in the switch it says it is an invalid command: 

Invalid input -> help
Type ? for a list

You can enter show sys in the AP to get the IP address and the mac address while you are in this mode:

ruckus# show sys



If you have an ICX 7150 I suggest that you access via console the switch, you need a USB type C cable for that.


New Contributor

OK...thank you for your response.  It helped me confirm that I was viewing the AP instead of the switch.  I also tried again to use the TypeC to USB after downloading driver and still could not get it to show up on laptop. 


I was still not able to access the switch. Part of the confusion was between Web GUI for switch vs the Unleashed Dashboard.  These are 2 different logins with what appears to be 2 different purposes. 

I also kept trying to identify the switch IP address thinking maybe i made a mistake or maybe the router assigned a different address within its range. The switch IP did not show up using Advanced IP Scanner.


So I went to my Edge router to identify the port connecting to the switch and confirmed its IP address.  It was what I had thought, but typing the IP in URL went nowhere, so I just unplugged all APs from switch.  Of course this caused me to lose my internet so i connected laptop directly to an unused port on my router to bypass switch for this test.  I then typed in the IP address of switch and IT SHOWED UP!  The master AP was blocking my switch IP address?? crazy.

I then logged into Web GUI (which is not the same un + pwd as Unleashed Dashboard) and went through steps noted in previous posts and finally got it to boot from correct partition.

whew...I think feat comes close to cycling a double century 😀


Hi MylesFlowers


Thank you for contacting Lennar Home Community.

Hope you are doing well!!!

Apologies for the delayed response on this.

From the case description, I could understand that you have RUCKUS ICX-7150-C12P Switch and there are connectivity issues. And you are trying to get Switch CLI Access to perform the command.

Please refer to the links and guides later in this post to know getting CLI Access to the Switch and about fixing this issue.

This issue may happen when the Switch runs on the Routing code. The Switch should run on the Switching code to avoid these issues for Lennar home users. If the Switch boots up on the other partition (Due to a power outage may be) which may be running on a ‘Routing Code’ results in causing this issue.

You can take Console access to the switch in order to verify, if the switch is able to connect properly to Access Points or if it has a ‘Routing Code’ issue which happens due to power outages most of the time, this is a known issue for Lennar home users.


An identifier of this problem is that it comes out as Switch-Router in the unleashed dashboard.

There we are going to see 2 important things the

-MAC address: Physical address of the device this never changes

- An IP address is a unique address (logical) that identifies a device on the internet or a local network like your home (this can change and may not be the same as the one shown on the dashboard)

Please follow the below steps:

  1. To fix this issue, we must identify the ‘current’ IP address assigned by your local router to the switch ICX-7150-C12P

I will leave you a guide on how to perform an IP scanner on your local network to identify the switch IP address very easily. 

How to find my Ruckus “Devices IP address” using free applications:

  1. Once we identify the IP address of the switch proceed to access remotely to the device “Command Line” 

How to remotely access to 'ICX 7150-C12P' or 'access points' "Network devices":

If you can access the Command line should look like this:

ICX7150-C12 Router>

  1. Here is a quick guide for understanding how to fix the 'routing code issue' however, you only need to run the following commands once you are on the command line 'CLI' 

Note: Hit Enter to accept each command


show version

copy flash flash secondary 

boot system flash secondary yes 


(Please share the output screenshot of the ‘show version’ command)



ICX7150-24P Router>enable (hit enter to accept the command)
ICX7150-24P Router#copy flash flash secondary (hit enter to accept the command and wait: until the flash finished)
ICX7150-24P Router#boot system flash secondary yes (hit enter to accept the command: the switch will reboot)

There are Two ways to fix this issue:

I) How to Fix Routing code issues on Lennar Home users via CLI

II) Or WEB access option


  1. If access via IP address is not possible here is a guide on how to access to the Switch via console (cable access between your PC to the ICX 7150-C12P) in this case we need a USB type C to USB standard or Console cable Rj45 to USB. 

How to console in the ICX-7150-C12P

Once you are logged in to the ICX-7150-C12P please follow up the same steps that are on point '3'


Please let me know if you have any queries in this regard.

Best regards,

Imran Sanadi

Lennar Home Community.