Showing results for 
Search instead for 
Did you mean: 

Ruckus Switch ICX 7150-C12P shows disconnected in Unleashed - Slow Internet connection

New Contributor

After a recent power outage, my Ruckus Switch ICX 7150-C12P shows as disconnected in Unleashed ios app.  Also, the internet connectivity over the broadcasting Wi-Fi channels on Access Points (Ruckus Zone Flex R320) is extremely slow.  I tried the recommended power re-cycle and factory reset on the switch but could not be able to fix the problem.  The lights on the Switch and Access points are all GREEN.  Please assist to resolve this.



Hi @GBS 


Based on your description,  it looks like your switch (ICX7150 Switch) maybe booting from the wrong partition (routing code issue) that this issue is going to lead to multiple connectivity issues like web pages loading slow / drooping connectivity , the switch showing as connected or disconnected in the app or  unleashed dashboard not affects the performance.




An identifier of this problem is that it comes out as Switch-Router in the unleashed dashboard.

There we are going to see 2 important things the

MAC address: Physical address of the device this never changes

An IP address is a unique address (logical) that identifies a device on the internet or a local network like your home (this can change and may not be the same as the one shown on the dashboard)

1- To fix this issue, we must identify the ‘currently’ IP address assigned by your local router to the switch

-We can try the IP address that shows in the dashboard copy and paste it in the URL if that redirects you to the login page for the ICX-7150-C12P that is the correct one if not.

I will leave you a guide how to perform an IP scanner on your local network to identify the switch IP address very easily. 

How to find my Ruckus “Devices IP address” using free applications

2-Once we identified the IP address of the switch proceed to access remote to the device 'command Line' 

How to remotely access to 'ICX 7150-12P' or 'access points' "Network devices"

If you can access to the Command line should look like this:

ICX7150-C12 Router>

3-Here is a quick guide to understand how to fix the 'routing code issue' but basically you need only need to run the following commands once you are on the command line 'CLI' 

Note: Hit Enter to accept each command


copy flash flash secondary 

boot system flash secondary yes 


ICX7150-24P Router>enable (hit enter to accept the command)
ICX7150-24P Router#copy flash flash secondary (hit enter to accept the command and wait: until the flash finished )
ICX7150-24P Router#boot system flash secondary yes ( hit enter to accept the command  : the switch will reboot )

How to Fix Routing code issues on Lennar Home users via CLI

Or WEB access option

4-If the access via IP address is not possible here is a guide how to access to the Switch via console (cable access between your PC to the ICX 7150-C12P) in this case we need a USB type C to USB standard or Console cable Rj45 to USB. 

How to console in the ICX-7150-C12P

Once you are log in the ICX-7150-C12P please follow up the same steps that are on point '3'


Best regards,


Lennar Home Community



I have the same issue and tried to follow all of your instructions but none of my options look like what posted, nor do the same commands work. I have attached pictures of what it looks like for me on my end. Please help.

Hi @Sainttravant 


Thank you for contacting RUCKUS Lennar Home Community.

Hope you are doing well.

As this case is raised by @GBS 

To avoid confusion with posts, you can create your own post on this RUCKUS Lennar Community forum with the problem you're facing and a detailed description of the network issue and what you've done so that we can guide you properly.

Thank you again for understanding.

Kind regards,

Sofia Gätjens