Showing results for 
Search instead for 
Did you mean: 

Ruckus ISC 7150 C12P not powering access points after power outage

New Contributor

We had a recent power outage and the access point within the home are not working. In the past I have been able to power reset these systems and they reboot effectively. This time this has not worked and it seems that my Ruckus system is stuck in boot mode with an orange light for SYST and a green light for power. 

I have spent a couple days looking over similar posts about this topic and have tried resetting the device and have installed the drives, upgrade, putty, MobaXterm, and other things. None of these seems to work at all and have just led to me wasting hours. 

The issue with the rest and that all the lights flash orange for hours and nothing actually happpens. 

The issue with doing these putty and MobaXterm and they both require the system to put in a "com" from the "ports." I have used three different computers and both the ethernet and the USB C connections and none of them have this COM show up in any circumstance. 

Can someone please explain to me how to get this device out of boot mode and working. Please do not refer me to another post I have looked over the other posts on this form and it has not led to any success. 


Hi @ClemTigers 

Thank you for the response and for sharing the requested information.

This Switch unit Should be RMA (Return Merchandise Authorization) in simple words replacing it.

Feel free to contact us via chat, comment you already have a post, copy the link from the post (URL) and paste it into the chat to start the unit replacement.

Please follow the steps as shown in the below example:

As shown in the below picture, copy the link and share it via chat from the link provided below:


The below link is to contact us by chat (only)

NOTE: Please feel free to mark the post as ACCEPTED SOLUTIONS.

Please let me know if you have any queries in this regard.

Kind regards,

Sofia Gätjens

View solution in original post



Hi @ClemTigers 

Could you please let us know the answers to the below queries to assist you better?

1. Was this working before or is it a new installation? If it worked before, was there any power outage before you started facing this issue?

2. On your switch while it's plugged into the outlet, do you see any lights on? (Amber or green) Please let us know which lights are on. (Please refer to the below picture and share a picture of the same, showing the light status and the FULL Switch panel cable connections to the Switch ports)

3. Is your Internet Connection from the Internet Service Provider (ISP) stable and working? (You could check this by connecting to your local router Wi-Fi or from an ethernet cable from the Router to a laptop/PC).

4. May I know how many Access Points are connected to the Switch? Could you please let me know the light status on the Access Points? Any of these lights are on (Please refer to the below picture and share a picture of the same)

Please help us with pictures of your ICX-7150-C12P Switch showing the status of the lights and cable connections to the Switch ports. Also, light the status of Access Points.

Before uploading the photos please log in to the RUCKUS account and you can upload the image.

Kind regards,

Sofia Gätjens

1. The system has been working for ~3 years before this power outage.

2. There is an amber light on SYST and a green light on power. When I reset it, there are many amber lights flashing endlessly. 

3. My internet is fine, and working. 

4. There are three different access point, with no lights on any of them.  


Hi @ClemTigers 

Thank you for the detailed information you shared.
As you mentioned there are lights on PWR and SYST, if there is an amber/orange light on the "SYST" and a green light on the "PWR" on the Switch (as it is in the below picture). Meaning the Switch is stuck in the boot mode.

Basically, due to the power outage/ power spike, the switch went to a state that we call ‘boot mode’ that is not able to boot up properly. And this is the reason your RUCKUS ICX-7150-C12P Switch is unable to transmit power (PoE- Power over Ethernet) to the Access Points or on its ports.

Please follow the below steps to fix this issue:

As you mentioned that you tried reset, once again we will try to reset the Switch as described below:

  1. Please try to disconnect from the Power outlet the ICX-7150 and reconnect.
  2. Please try to press the reset button using a paper click or a small stick 
  3. Remove power from the switch.
  4. Press and hold the Reset button while applying power to the switch.
  5. After all the system LEDs flash amber, release the Reset button.

Below is the Guide and Videos link for your reference:

Video link:

IF THE RESET IS NOT WORKING, PLEASE TRY TO RESET YOUR SWITCH MULTIPLE TIMES (Like 10-15 times) AS DESCRIBED ABOVE. As we have seen it working sometimes after trying multiple times in many cases. If the reset with a paperclip works, the SYST and PWR lights should turn GREEN.

IF RESET DOESN’T WORK: Please follow the below steps.

If the reset does not make any difference, we need to perform a software recovery since it can be that the image flash is corrupted in basic words the unit is not able to boot up properly and need re-install the image to boot up properly.

Below is the Guide and Video Link to perform the Software recovery process:

Please refer to the below guide and Video link:

Video Link:

Please note, we must use ethernet cable (both ends RJ45 plugs) and USB to type C cable both together as described in steps 2 & 3 in the guide link.

To access by console must install a driver so that the workstation/pc/desktop or laptop can recognize the cable

Make sure to download the zip drive for the file below & "extract all". Once it's extracted, run the file ,driver should be installed.



How to console in the ICX-7150-12CP 'Ruckus Switc

Feel free to contact me if you have questions. 

Kind regards,
Sofia Gätjens

Thank you for you response. The reset is suppose to have the flashing lights for how long? I have waited 15 hours at my longest so far. 

I have already tried all of this before and it doesn't work. The issue I have with the second process is that I do not have a COM under "port" when connected. Therefore, there is no way to do the steps provided in the previous answer. Do you have other suggestions?