Showing results for 
Search instead for 
Did you mean: 

ICX 7150 stuck in boot mode and non responsive

New Contributor


My ICX 7150 switch that came with my Lennar Home is stuck in boot mode after a power outage. I have an iMac computer and have followed the instructions for a reinstalling the drivers and software. When connected to the computer via USB to C cord and ethernet cable it does not even detect my ruckus switch. My unit is completely bricked and unresponsive. Please advise for further steps to resolve issue. Thanks.


Hi @Drewshreeve1

We cannot replace the chassis until you confirm that the hardware is damaged.
We have tried to create the guides as non-technical as possible, so that they are not difficult to follow; however, if you continue to have difficulty following the steps,
I would recommend that you seek outside help or a technician.

Best regards,


Lennar Home Community




Hi @Drewshreeve1

Basically if the switch has one green and one yellow light, it means that the switch is stuck in boot mode.

1-Please try to disconnect from the Power outlet the ICX- 7150 and reconnect it.

2-Please try to press the reset button using a paper click or a small stick 

  1. Remove power from the switch.
  2. Press and hold the Reset button while applying power to the switch.
  3. After all the system LEDs flash amber, release the Reset button.

Video link:

If this step doesn't work, we need to perform a software recovery.

Here is the quick guide to perform software recovery.

How to perform a Software recovery on an ICX7150 switch

Ruckus ICX Recovery Load boot code from boot monitor

Note: after fixing the issue of the Switch been stuck in boot mode, please perform an upgrade to the code 08095g UFI and upgrade both partitions with the switching code file named SPS08095gufi.bin, so perform the software recovery using the code 08090k with the upgrade image file named SPS08090k.bin, then when the switch is back to normal upgrade to the file SPS08095gufi.bin for both partitions primary and secondary.

1.Upgrade a Switch ICX-7150-C12P using a USB flash drive

  1. Upgrade a Switch ICX7150-C12P via TFTP

  1. Upgrade a switch via Web GUI (ICX7150 Switch)

Best regards,


Lennar Home Community

I have tried your instructions and my computer doesn’t even detect the Switch. I have uploaded pics to this thread showing the hookup to my iMac and the ruckus switch. I have a pretty good knowledge of computers and this is pretty frustrating. 

I have correctly connected the switch to my computer and it is non responsive and the computer does not detect it. I have provided pictures on this thread to show my connection. I unfortunately can not complete a software recovery because the switch is completely non responsive. Please advise for further steps to resolve issue. Thank you.