Showing results for 
Search instead for 
Did you mean: 

ICX 7150 UBIFS Error

New Contributor III

I've searched for this issue I am having on the board and it seems a few others have run into the same problem, but I don't know how to get support for myself so I'll reiterate quickly here.

Woke up after power outage and internet was out; no lights observed on the APs. SYST light on the switch was flashing green. I unplugged the switch and plugged it back in and no change. I then performed a hard reset as per the instructions on the forum and looked at the output from the console using PuTTY. Error is given below:

Starting kernel ...

booting with 4.4 kernel
NAND Type: Micron NAND 2GiB (x 1)
dd cmd: UBI
ubi0 error: ubi_io_read: error -74 (ECC error) while reading 1040384 bytes from PEB 327:8192, read 1040384 bytes
UBIFS error (ubi0:0 pid 565): ubifs_recover_leb: corruption -3
UBIFS error (ubi0:0 pid 565): ubifs_check_node: bad node length 8389680
UBIFS error (ubi0:0 pid 565): ubifs_checks_node: bad node at LEB 1209:839680

There is also a soft lockup CPU#0 stuck for 34s error message as well.

I lastly followed a guide from the forum on performing a software recovery for the ICX 7150 and that did not work either.

How I can I get this thing working? All my security devices and others rely on the APs.


Hi @chris_marquez_k 


Thank you for the response and for sharing the requested information.

Based on the troubleshooting done, you confirmed, and we saw that after the reset, booting up the Switch, and trying the software recovery process multiple times, the failure persists. This Switch unit Should be RMA (Return Merchandise Authorization) in simple words replacing it.

Feel free to contact us via chat, comment you already have a post, copy the link from the post (URL), and paste it into the chat to start the unit replacement.

Please follow the steps as shown in the below example:

As shown in the below picture, copy the link and share it via chat from the link provided below:

The below link is to contact us by chat (only)

Please let me know if you have any queries in this regard.

Thank you again. We appreciate your patience and understanding.


Best regards,

Imran Sanadi

RUCKUS Lennar Home Community.

View solution in original post


New Contributor III

Sorry, forgot to mention it is the C12P version, if that matters. Thank you.

Hi @chris_marquez_k 


Thank you for contacting RUCKUS Lennar Home Community.

Hope you are doing well!!!

Thank you for the information you shared.

As per the case description, I understand that your RUCKUS setup is not working, and Access Points do not have power after a power outage.

Could you please let us know the answers to the below queries to assist you better?

1. On your switch while it's plugged into the outlet, do you see any lights on? (Amber or green) Please let us know which lights are on. (Please refer to the below picture and share a picture of the same, showing the light status and the FULL Switch panel cable connections to the Switch ports)

2. Is your Internet Connection from the Internet Service Provider (ISP) stable and working? (You could check this by connecting to your local router Wi-Fi or from an ethernet cable from the Router to a laptop/PC).

3. May I know how many Access Points are connected to the Switch? (Please refer to the below picture and share a picture ALL of them)

Please help us with pictures of your ICX-7150-C12P Switch showing the status of the lights and cable connections to the Switch ports. Also, light the status of Access Points.

Before uploading the photos please log in to the RUCKUS account and you can upload the image.

Please let us know the answers to ALL the above queries or let us know if you have any queries in this regard.

Thank you again for your patience.


Best regards,

Imran Sanadi

RUCKUS Lennar Home Community.

Hi, Imran. I am doing well hope you are too!! Happy to provide more info. 

I do see lights on the ICX 7150, please see the pictures attached. The SYST light is solid amber. As I mentioned in my original post, I tried a hard reset according to the guide on this forum and it did not allow the switch to boot. I then followed another guide on this forum to do a software restore and it did not boot either. None of the 3 APs show any lights or signs of power. 

I can confirm that my ISP router and modem are working properly. I was able to borrow a friends Unifi switch and connected the same cables in the same way they are connected to the ruckus switch, and the APs came to life and internet worked. I had to give the switch back, but it proves the APs work and its the ICX 7150 that is busted.AP 1 LightsAP 1 LightsAP 2 LightsAP 2 LightsAP 3 LightsAP 3 LightsICX Lights 1ICX Lights 1ICX Lights 2ICX Lights 2ICX Lights 3ICX Lights 3PuTTY Error LogPuTTY Error Log


Hi @chris_marquez_k 

Thank you for the response and the detailed information you shared.

As you mentioned and I can see from the pictures you shared, there are lights on PWR and SYST, if there is an amber/orange light on the "SYST" and a green light on the "PWR" on the Switch (as it is in the below picture). Meaning the Switch is stuck in the boot mode.

Basically, due to the power outage/ power spike, the switch went to a state that we call ‘boot mode’ that is not able to boot up properly. 

Please follow the below steps to fix this issue:

As you mentioned that you tried reset, once again we will try to reset the Switch as described below:

1. Please try to disconnect from the Power outlet the ICX-7150 and reconnect.

2. Please try to press the reset button using a paper click or a small stick 

  • Remove power from the switch.
  • Press and hold the Reset button while applying power to the switch.
  • After all the system LEDs flash amber, release the Reset button.

Below is the Guide and Videos link for your reference:

Video link:



IF RESET DOESN’T WORK: Please follow the below steps.

If the reset does not make any difference, we need to perform a software recovery since it can be that the image flash is corrupted in basic words the unit is not able to boot up properly and need re-install the image to boot up properly.

Below is the Guide and Video Link to perform the Software recovery process:

Please refer to the below guide and Video link:

Video Link:

Please let me know if you have any queries in this regard.

Thank you again for your patience and understanding.


Best regards,

Imran Sanadi

RUCKUS Lennar Home Community.