Showing results for 
Search instead for 
Did you mean: 

Factory Reset Unsuccessful

New Contributor

I have a Ruckus ICX 7150-C12P unit that shows a solid green light (PWR) and a solid amber light (SYST). I have tried a factory reset multiple times, but the lights always return to this configuration. Looking at other posts, I see instructions on how to correct a software problem. Unfortunately I am not computer-savvy and most of the instructions read like a foreign language to me. I have a Mac and I am totally lost in these instructions. Do you have any advice for someone like me who needs a little extra help in understanding my next steps?


Hi @Wxdude 


Thank you for the response and for sharing the requested information.

Based on the troubleshooting done, you confirmed, and we saw that after the reset, booting up the Switch, and after trying the software recovery process, the failure persists with no response from the management port on CLI. This Switch unit Should be RMA (Return Merchandise Authorization) in simple words replacing it.

Feel free to contact us via chat, comment you already have a post, copy the link from the post (URL) and paste it into the chat to start the unit replacement.

Please follow the below steps as shown in the below example:

As shown in the below picture, copy the link and share it via chat from the link provided below:

The below link is to contact us by chat (only)

NOTE: Please feel free to mark the post as ACCEPTED SOLUTIONS

Please let me know if you have any queries in this regard.

Thank you again and we appreciate your patience.


Best regards,

Imran Sanadi

RUCKUS Lennar Home Community.

View solution in original post



Hi @Wxdude 


Thank you for contacting RUCKUS Lennar Home Community.

Hope you are doing well!!!

Thank you for the information you shared.

As per the case description, I could understand that your ICX-7150-C12P Switch is stuck on boot mode and you tried reset of the same.

As you mentioned there are lights on PWR and SYST, if there is an amber/orange light on the "SYST" and a green light on the "PWR" on the Switch (as it is in the below picture). Meaning the Switch is stuck in the boot mode.

As you mentioned that you tried reset, once again we will try to reset the Switch as described below:

1. Please try to disconnect from the Power outlet the ICX-7150 and reconnect.

2. Please try to press the reset button using a paper click or a small stick 

  • Remove power from the switch.
  • Press and hold the Reset button while applying power to the switch.
  • After all the system LEDs flash amber, release the Reset button.

Below is the Guide and Videos link for your reference:

Video link:



IF RESET DOESN’T WORK: Please follow the below steps.

Please use a windows Laptop/Pc for software recovery if you have one.

If the reset does not make any difference, we need to perform a software recovery since it can be that the image flash is corrupted in basic words the unit is not able to boot up properly and need re-install the image to boot up properly.

Below is the Guide and Video Link to perform the Software recovery process:

Please refer to the below guide and Video link:

Video Link:

Please let me know if you have any queries in this regard.

Thank you again for your patience.


Best regards,

Imran Sanadi

RUCKUS Lennar Home Community.

Thank you for your detailed instructions. After 15+ attempts at a factory reset, all of which failed, I was able to secure the help of someone knowledgable with computers to go through the software steps, but unfortunately we only got as far as the PuTTY configuration. We did not get a boot> prompt in the window, as you can see in the photo below, so we could go no farther. My helper concluded that the unit must be faulty. Would you agree? If so, how can I go about getting a replacement?No boot promptNo boot prompt

Hi @Wxdude 

Thank you for the response and the update.

Apologies, if we are not getting prompt on Putty CLI, it doesn’t mean that the Switch is faulty. There may be some configuration issues, that we could check.

Please make sure to start Putty with the correct Serial connection as shown in the screenshots below. Please make sure you are using the correct COM port from the device manager.

If it is selected correctly, please help us with a screenshot of the Device Manager showing the COM ports. And also please help us with a picture showing the software recovery cable connections between the Switch and the Laptop.

Please let me know if you have any queries in this regard.

Thank you again for your patience and understanding.


Best regards,

Imran Sanadi

RUCKUS Lennar Home Community.

Thank you for your reply. Attached are the photos you requested showing the Device Manager and com ports. Also are photos showing the cable connections from the Switch to the Laptop. I appreciate any other feedback that you can provide.Config 2.jpgcable 1.jpgCable 2.jpgCable 3.jpgconfig 1.jpg