Showing results for 
Search instead for 
Did you mean: 

AP not working/no power: green lights on switch after factory reset

New Contributor

We have an AP that is not getting power (no lights) we have performed a factory reset and seem to have green lights on the switch. I read tutorials on it potentially being stuck on boot mode. I am not tech savvy in the slightest and this looks complicated to perform a software recovery.  Is there a contact or support line where I can receive assistance via phone or get an in home visit? Our smart home devices are also not connected And the ring is causing our doorbell to chime continuously. Please help! 



Hi @Scanlonjn

Effective November’2022, ‘Ruckus Support for Lennar Homes customers will no longer be handled by phone or email.
We will be exclusively supporting customers via this community forum support model.

Here I attach the guide to solve the issue. 

Basically if the switch has one green , it means that the switch is stuck in boot mode.

1-Please try to disconnect from the Power outlet the ICX- 7150 and reconnect it.

2-Please try to press the reset button using a paper click or a small stick 

  1. Remove power from the switch.
  2. Press and hold the Reset button while applying power to the switch.
  3. After all the system LEDs flash amber, release the Reset button.

Video link:

If this step doesn't work, we need to perform a software recovery.

Here is the quick guide to perform software recovery.

How to perform a Software recovery on an ICX7150 switch

Ruckus ICX Recovery Load boot code from boot monitor

Note: after fixing the issue of the Switch been stuck in boot mode, please perform an upgrade to the code 08095g UFI and upgrade both partitions with the switching code file named SPS08095gufi.bin, so perform the software recovery using the code 08090k with the upgrade image file named SPS08090k.bin, then when the switch is back to normal upgrade to the file SPS08095gufi.bin for both partitions primary and secondary.

1.Upgrade a Switch ICX-7150-C12P using a USB flash drive

  1. Upgrade a Switch ICX7150-C12P via TFTP

  1. Upgrade a switch via Web GUI (ICX7150 Switch)

We have tried to create the guides as non-technical as possible, so that they are not difficult to follow; however, if you continue to have difficulty following the steps, I would recommend that you seek outside help or a technician.

Best regards,


Lennar Home Community

New Contributor

We are having the exact same issue! 

Our switch Box has TWO green lights which, from what I've read, is not stuck in BOOT up Mode

It will take a Rocket Scientist to figure out what is wrong. Please let me know if you have any positive results.

Hi @Randy

When all the system LEDs blink green after the factory reset, all the configuration data are erased and the switch is returned to its factory configuration. When all the system LEDs are solid green, the erase process is complete and the system reloads. Once reloaded and the SYST LED is steady green, the factory reset is complete.

If the Switch is not responding to the factory reset, you need to perform the software recovery process.

Please read the guide carefully before start the steps.

How to perform a Software recovery on an ICX7150 switch

Ruckus ICX Recovery tutorial video

Best regards,


Lennar Home Community

I’ve been trying to upgrade my Ruckus switch to regain Wi-Fi and setting up connection between switch and computer and when I go to device manager and click on (COM & LPT) there are no com choices just virtual. I tried inputting the virtual com but Putty doesn’t recognize them. I’ve been attempting this for the better part of nine hours now. Really frustrated. Any ideas?

Thank you,