Showing results for 
Search instead for 
Did you mean: 

Ruckus ICX 7150 not powering on all of sudden after a power shutdown in the community

New Contributor


   We tried all the suggestions including :

and tried upgrading firmware.

The steps were completed successfully (though I could see lots of crash messages on the console), still, the device only has 2 lights as shown in picture and wifi extender does not power on.1.jpeg2.jpeg3.jpeg



    We did try the command:

setenv image_name SPS08090k.bin


The error we get is:

Primary image download failed

Hi @sebastso 


Thanks for your response.



Please share the screenshot of the error you are getting while following the steps.




Best regards,


Lennar Home Community






Attached the screenshot, see the error:Primary image download failed


Hi @sebastso 


Please enter the below commands and retry the software recovery process and share the output.


setenv ipaddr”    (assign an IP address to the switch, As you see I just change the last digit instead 2 as my computer I used 3)

"setenv gatewayip"   (default gateway of your network, which will be your own computer as well)

 “setenv netmask”  (net mask belonging to the network, matching with the same found from the CMD)

 “setenv serverip”  (enter the IP address of the TFTP server, means the computer wire to the Switch on the management port)

"printenv"  (check the values you recently change)


- Enter command saveenv to save the changes





Please let us know if you have any queries in this regard.


Best regards,


Lennar Home Community


Dear Jayavidhya, with all respect, after fighting this issue for 3 weeks, I have already set up the IP address as given below (as it was clearly mentioned in the article:
I followed the exact steps & I'm stuck at error: Primary image download failed while executing update_primary command, see the screenshot attached, I have set IP address as : for the switch and TFTP server as : (exactly as the article mentioned) tftp_failing2.jpeg