Showing results for 
Search instead for 
Did you mean: 

Need replacement Ruckus Switch

New Contributor

Hello, in the past 2 years, the Ruckus switch has failed 3 times (all 3 in the past 7 months) it is currently out again, and I am unable to reset it. The model no. is  ICX7150-C12P. I have tried resetting it. Frustrating as this keeps failing. 

Thanks, Gopal


I will do it, but this is the 3rd time I have to do this tedious process to get it to run again, in the last 7 months, so obviously something is wrong with the switch. 

Hi @rama9998 


As per the information you have shared, if the switch has green and amber light it means that the switch is stuck in boot mode. 


It is a software related issue so we don't need to replace the switch. 


For detailed understanding of the issue please share the screenshot of the error you are getting while performing the steps.


Best regards,


Lennar Home Community

New Contributor

I tried resetting to factory default. all status lights keep blinking forever. I am not able to do the software recovery since i am unable to find out the COM# as windows says driver is not installed for network adapter. 

error in device manager

New Contributor

I am unable to locate port under network adapter as per your instructions

New Contributor

I notice that the blinking lights have gone, Status is green, SYST is green and all the 3 ports are blinking. Now i have a different problem - I tried to login through the unleashed app. Unleashed home, Manage Network, login as admin and add my password, I am getting a "Unable to reach Unleashed Network" error. Can you please help?