Showing results for 
Search instead for 
Did you mean: 

ICX7150-C12P — how to reconnect

New Contributor



Previously, my ICX7150-C12P switch with two APs was working. I can’t figure out how to go back to broadcasting.l (now, one of them only has a solid green light at PWR and DIV and AIR, 2.5Hz and 5 Hz are not lit up, while on the other AP, the PWR light is green but the DIV light is flashing green slowly — is that just because the first is the master?) The switch is on — I think that the correct lights are on, but I can’t use the web or app way of accessing the switch and I don’t see the Config-… network (because I had set it up to be under my WiFi name). 

1. Should I do a factory reset of the ICX7150-C12P switch? That didn’t work. I can’t factory reset the APs because they are on the ceiling. 

2. Should “1” fix the issue (do I need to plug my laptop directly into the switch?)

3. As an aside, when I need a very reliable connection I run an Ethernet cable from the switch to my laptop — where should I be plugging the Ethernet cable in to on the switch — it seems to work when plugged into two different places: a. One of the 12 POE ports; or b) C1/C2?. 

4. What is the port right above the USB port for?

5. What is the port that is labeled “I o I o l” for?



Hi @Jdoherty 


Greetings of the day,


Thanks for the detailed description,


3) Based on the images you have shared it seems like the ethernet cable coming from the router or the access points has to be connected to one of the 12 ports of the switch.



Make sure the cable is in good condition so that both ends and connectors look good.


Note : you will see a light come on when a device is connected via Ethernet on 1 of the 12 ports available.


Here I will leave a short guide how to connect the devices properly : 


Most common Setups for Lennar homes users







Once you are done with the above step please check the LED status of the Access points and let us know the result.


Also to check the ports here I share the guide which gives the detailed description of the LED ports of the switch.



Please let us know if you have any queries in this regard.



Best regards,


Lennar Home Community

Thank you @jayavidhya for the reply.

i plugged the Ethernet cable that runs from the Ruckus switch to the laptop into one of the 12 POE ports.



 This didn’t change anything — I tried to access unleaded with it plugged in and not, and there is still no AP broadcasting. 

both APs have a green light at PWR and SYS and nothing else.


Why aren’t the APs broadcasting, and what can I do about it? 


Thank you.

Hi @Jdoherty 


Thanks for your response,


To solve this issue please try to do the physical factory reset of the access points using the below steps and check the LED status of the access points.


IMPORTANT NOTE: As you have two Access Points (APs) in your house, please make sure you only keep the affected AP ON and reset the same. Please go to the Ruckus Switch (located in the panel) and disconnect from its ports the Ethernet cables of the Working Access Point, except the one that you are going to work with (non-working).



Please read the following guide carefully: 


Physical Factory Reset of RUCKUS Access Point:


Ruckus Unleashed Set-up using your Mobile:


Ruckus Unleashed Set-up using Web:


Please let us know if you have any queries in this regard.



Best regards,


Lennar Home Community

Thank you @jayavihya — I have some follow-up questions after reading all the material and watching the videos:

1. In your last response, you wrote in bold that I should disconnect the “working AP.” In the link that you sent me, it says to preferably keep the master AP attached.

Since both of my APs seem to have the same issue, do I keep them both connected or do I disconnect the slave and work on the master (or vice versa)?

2. In the second video from your link, they explained that when you first get the AP, you should plug it directly into the modem/router but then it says to plug it into the switch. Since I know that my switch is receiving internet from the modem/router, do I just ignore this part, and simply reset the AP? 

3. Should I do the full factory reset or just the more simple reset first (in the first video it seems to really warn against keeping the reset pushed after it turns red (but in the first link it says to keep  pushing for 10-20 seconds after it turns red)?

4. If the answer to “3” is to do a full factory reset, is there any reason to think that a normal reset would help and to try it first (what does the non-factory reset do?)?

5. From a practical point-of-view, the APs are on the ceiling — would there be enough room to access the reset button without having to find something to use as a key to unlock it from the ceiling?

6. Since I don’t have a key, do you have any recommendations on what I can use instead — from the video it sounds like a paper clip would not be strong enough.

Thank you very much!