Showing results for 
Search instead for 
Did you mean: 

ICX7150-C12 Switcher in router mode. can't get a connection between laptop and switcher

New Contributor

I have an elderly neighbor who asked me to help him with his Ruckus setup. We both live in Lennar homes. 

His ICX7150-C12 Switcher is disconnected (according to Ruckus Unleashed dashboard), but the internet is connected and works intermittently. I have restarted/reset all combinations of his APs, Switcher, and Internet Modem. No success. He said that is hasn't been working properly the entire time since he moved in (little over 2 years). He just has been using the wifi coming from his AT&T modem. 

His switcher gives an error message that states "Failed to ping ICX, Suggest checking the network." I also realized (from searching these forums) that the name of his switcher is ICX7150-C12 Router, which is not a good thing, its in router mode. 

I have been using the above article to try to connect my laptop to his switcher to help get it back in switcher mode. 

I have a 2019 Macbook Pro running Monterrey OS. I connected my laptop to the switcher using a serial console cable with an RJ-45 connector. I have also installed both drivers mentioned in the article. 

When I open the terminal and type in the command to get access to the Switcher Command Line, I am getting a different log than what I am looking for. There is no reference to the SiLabs_Serial driver. When I try to put in any further commands, nothing works. 


Need help. What am I doing wrong? How do I properly get the ICX and computer to talk to each other? 


Hi @farmer120 

Did you reboot the Switch, take into consideration that, one steps will be changing the boot sequence, (ensure you did not get any error), then a reload to the Switch from the WEB GUI is necessary.





Please, share a screenshot of the steps.

Best regards,

Yarenis Hernández.

Technical Support Engineer | L2 TAC Wired | Lennar Home Community

Hi Yarenis, 


Thanks for the above help. I did do a re-boot last time.

Tonight here is what I did. 

I opened the switcher boot command (here is a screenshot prior to doing anything). Screen Shot 2023-01-02 at 8.22.24 PM.png

Then I proceeded to follow the steps. I deleted the primary flash sequence and then added and saved it. 

Then I went down the menu to the reload (here is a screenshot before doing anything). 

Screen Shot 2023-01-02 at 8.22.50 PM.png

I did a reload. Took about 10-15 minutes for the switcher and APs to reload. Here is the results - 

(Screenshot of unleashed dashboard)

Screen Shot 2022-12-29 at 9.18.08 PM.pngScreen Shot 2022-12-29 at 9.19.05 PM.png

(Screenshot of APs, upstairs both 5G and 2.4G were working, downstairs only 2.4G is working)

Screen Shot 2023-01-02 at 8.49.05 PM.pngScreen Shot 2023-01-02 at 8.49.14 PM.png

Here are two pictures - one is the downstairs AP with the front lights and the other is the back of the switcher so you can see my cord connection. 


If there is any other screenshots or pictures you need, please let me know. I am truly stumped.

Hi @farmer120 

Hope you are doing well ! 

We can try to enable the Telnet protocol, and try accessing via CLI

Telnet .png

To access via via Telnet is the following command please open terminal on your machine :

nc IP-Switch 23


nc 23

nc 1921.68.0.3 23

Best Regards 

Fernando Vasquez 

Hi Fernando, 


Thank you for that information. That resolved the issue! Thank you so much. 

Can I suggest a change to your overall "fix the router mode issue" post? As a mac user, I followed the instructions and nothing worked. The fix from you in the above post is simply telling people to turn the telenet function on in the WEB GUI. I never saw that change at all in any of the public posts. One I changed that, my terminal/telenet access worked right away and the issue was resolved in minutes. If that had been in the public pinned post, I would have never had to ask multiple questions and post multiple screenshots. 


Thank you for your help