Showing results for 
Search instead for 
Did you mean: 

ICX7150-C12 Switcher in router mode. can't get a connection between laptop and switcher

New Contributor

I have an elderly neighbor who asked me to help him with his Ruckus setup. We both live in Lennar homes. 

His ICX7150-C12 Switcher is disconnected (according to Ruckus Unleashed dashboard), but the internet is connected and works intermittently. I have restarted/reset all combinations of his APs, Switcher, and Internet Modem. No success. He said that is hasn't been working properly the entire time since he moved in (little over 2 years). He just has been using the wifi coming from his AT&T modem. 

His switcher gives an error message that states "Failed to ping ICX, Suggest checking the network." I also realized (from searching these forums) that the name of his switcher is ICX7150-C12 Router, which is not a good thing, its in router mode. 

I have been using the above article to try to connect my laptop to his switcher to help get it back in switcher mode. 

I have a 2019 Macbook Pro running Monterrey OS. I connected my laptop to the switcher using a serial console cable with an RJ-45 connector. I have also installed both drivers mentioned in the article. 

When I open the terminal and type in the command to get access to the Switcher Command Line, I am getting a different log than what I am looking for. There is no reference to the SiLabs_Serial driver. When I try to put in any further commands, nothing works. 


Need help. What am I doing wrong? How do I properly get the ICX and computer to talk to each other? 


New Contributor

Thanks. I think my question was confusing. 

When I go to do this step - "To access the remote switch using a MAC PC we must open the terminal" 

Does my laptop need to be connected to the switcher? 

Thanks for the help. I couldn't get the telnet or SSH options to work. 


I tried the Web Access option. So I can't do anything on the Wifi through the ruckus (I can only go to the unleashed dashboard and see what is going on with my network). So I jumped to the AT&T wifi from the modem and got the correct ip address of the switch. 

I followed the directions to reboot the switcher in the Web GUI. My switcher was already in the primary flash boot sequence. I followed the instructions and re-booted the switcher in the primary flash again. Nothing was resolved or changed. I will try to attach pictures of my Ruckus Switcher dashboard

One thing to note on the screenshots below - 


The last time this switcher worked properly was Sept 2019. WE MOVED IN NOV 2020. So was thing switcher set up properly at all (we did have Amazon techs come out in the first few months after we moved in, but it seems to me that it never was set up properly due to it NEVER working since we have been in the house). 

Screen Shot 2022-12-29 at 9.03.17 PM.png

New Contributor

These are the images of my switcher dashboard. I am not sure what to do next. Please help!


Screen Shot 2022-12-29 at 9.04.37 PM.png

New Contributor


This is my Unleashed Ruckus Dashboard. So you can the internet status and switcher disconnected. 

Screen Shot 2022-12-29 at 9.18.08 PM.png

Screen Shot 2022-12-29 at 9.19.05 PM.png