Showing results for 
Search instead for 
Did you mean: 

ICX7150-C12 Switcher in router mode. can't get a connection between laptop and switcher

New Contributor

I have an elderly neighbor who asked me to help him with his Ruckus setup. We both live in Lennar homes. 

His ICX7150-C12 Switcher is disconnected (according to Ruckus Unleashed dashboard), but the internet is connected and works intermittently. I have restarted/reset all combinations of his APs, Switcher, and Internet Modem. No success. He said that is hasn't been working properly the entire time since he moved in (little over 2 years). He just has been using the wifi coming from his AT&T modem. 

His switcher gives an error message that states "Failed to ping ICX, Suggest checking the network." I also realized (from searching these forums) that the name of his switcher is ICX7150-C12 Router, which is not a good thing, its in router mode. 

I have been using the above article to try to connect my laptop to his switcher to help get it back in switcher mode. 

I have a 2019 Macbook Pro running Monterrey OS. I connected my laptop to the switcher using a serial console cable with an RJ-45 connector. I have also installed both drivers mentioned in the article. 

When I open the terminal and type in the command to get access to the Switcher Command Line, I am getting a different log than what I am looking for. There is no reference to the SiLabs_Serial driver. When I try to put in any further commands, nothing works. 


Need help. What am I doing wrong? How do I properly get the ICX and computer to talk to each other? 


Hi @farmer120 

If the web option is not working we need to SSH or Access via console using the USB type C to USB cable : 

If there was a blackout or power outage and the switch reboot because of that, most possible your switch starts running the wrong code which we call ‘routing code’ this is a know issue.




An identifier of this problem is that it comes out as Switch-Router in the unleashed dashboard.

There we are going to see 2 important things the

MAC address: Physical address of the device this never changes

An IP address is a unique address (logical) that identifies a device on the internet or a local network like your home (this can change and may not be the same as the one shown on the dashboard)

1- To fix this issue, we must identify the ‘currently’ IP address assigned by your local router to the switch

-We can try the IP address that shows in the dashboard copy and paste it in the URL if that redirects you to the login page for the ICX-7150-C12P that is the correct one if not.

I will leave you a guide how to perform an IP scanner on your local network to identify the switch IP address very easily. 

How to find my Ruckus “Devices IP address” using free applications

2-Once we identified the IP address of the switch proceed to access remote to the device 'command Line' 

How to remotely access to 'ICX 7150-12P' or 'access points' "Network devices"

Possible passwords and username for SSH access username : admin password : Lennar / username : admin password : Ruckus! / username : admin password : Ruckus1/ username : super password : sp-admin

If you can access to the Command line should look like this:

ICX7150-C12 Router>

3-Here is a quick guide to understand how to fix the 'routing code issue' but basically you need only need to run the following commands once you are on the command line 'CLI' 

Note: Hit Enter to accept each command


copy flash flash secondary 

boot system flash secondary yes 


ICX7150-24P Router>enable (hit enter to accept the command)
ICX7150-24P Router#copy flash flash secondary (hit enter to accept the command and wait: until the flash finished )
ICX7150-24P Router#boot system flash secondary yes ( hit enter to accept the command  : the switch will reboot )

How to Fix Routing code issues on Lennar Home users via CLI

Or WEB access option

4-If the access via IP address is not possible here is a guide how to access to the Switch via console (cable access between your PC to the ICX 7150-C12P) in this case we need a USB type C to USB standard or Console cable Rj45 to USB. 

How to console in the ICX-7150-C12P

Once you are log in the ICX-7150-C12P please follow up the same steps that are on point '3'

Best Regards 

Fernando Vasquez 

Hi Fernando, 

Thanks for the help above. I still can't get anything to work. 

First off, I am operating off the AT&T wifi cause there is no functionality on the Ruckus Wifi. Not sure if I need to be on the Ruckus wireless network to fix this switcher issue. 

I agree with you that I believe this to be a "router" issue as the dashboard image matches your screenshot above. 

We have abandoned the Web option. And proceeded to follow your steps - 

First is it alright to use the USB to RJ45 cable as well? Just wanted to confirm cause that is what I am using. This is response to the direction of "we need to SSH or Access via console using the USB type C to USB cable." 

If the RJ45 cable is ok to use, here is what I did tonight to try to fix the issue. 

My issue starts with getting access to the switcher via the command line. I used the link you posted and went through the directions. I don't have any Windows computers so I jumped to the Mac section involving Terminals. 

First I did follow this direction (the Telenet direction) - For Telnet access: nc ‘IP of the device’ 23

Couldn't get a connection. 

I tried the 2nd option using the SSH Access - 

No connection established. See the following screenshot with my Terminal code. Screen Shot 2022-12-30 at 8.32.21 PM.png


Then I tried the final step - "if access to ssh does not work tried the following ssh-keygen -R 'ip address of the device' this generates a public key pair for use when authenticating with a remote server."

No connection established. See my screenshot for the Terminal code. Screen Shot 2022-12-30 at 8.37.10 PM.png


Am I entering the wrong things into the Terminal? Why can't my laptop establish a connection with the Switcher via hardline? I can connect via the Web option.

Please read through my comment and respond to my direct questions. The last few times I keep getting copied and pasted the same routine answers and they are NOT working for me. Thank you for your help. 

Hi @farmer120 

You already have access to web Gui, if you follow up the guide you will be able to fix your issue from step#4


How to Fix Routing code issues on Lennar Home users via Web GUI.


Best regards,

Yarenis Hernández.

Technical Support Engineer | L2 TAC Wired | Lennar Home Community


New Contributor

Hi Yarenis, 

I have done this twice. Nothing is fixed. I was able to access Web GUI and did all of the steps. At step 4, the directions say to "force the switch to boot from the primary partition." 

When I clicked on boot sequence menu, the sequence was already coming from primary flash (not the secondary flash from the attached photos in the directions). I did the steps twice. Even deleting the boot sequence, and following the steps again. 

After the Switch and APs restarted, I am still getting this on my main dashboard. Screen Shot 2022-12-29 at 9.19.05 PM.pngScreen Shot 2022-12-29 at 9.18.08 PM.png

When I went back into the Web GUI, the boot sequence menu still had the switcher loading from primary flash