Showing results for 
Search instead for 
Did you mean: 

ICX switch internal h/w fault

New Contributor II


I observed 1 of my AP is not getting power. Also, the APs are not providing internet. I saw on the switch that the ethernet ports are not lighting green color. So I started a console session with the switch. With the command `show inline power` I found that 6 of the 8 ports are showing `internal h/w fault` 

Please help me with next steps. Is the switch having hardware failures? 


New Contributor II


I finally got connected to the internet. Switch is working and APs are connected. Here is a recap of what happened.

  1. H/w failure error
  2. Contacted Ruckus customer service here and got an RMA for replacement
  3. Received RMA
  4. Connected to new Switch and accessed the console and logged in
  5. Switch asked me to change default password, changed it
  6. Then connected the 3 APs to the switch. Did not connect the ethernet wire to switch from my router
  7. The 3 APs are still transmitting Recover.Me
  8. I followed instructions here to hard reset each AP
  9. As part of the process, I connected only 1 AP to the Switch
  10. Even after hard resetting of only that 1 AP, the Unleashed app is not able to configure a WLAN
  11. On the AP, the CTL is blinking fast, meaning receiving configuration or image upgrade
  12. Even after waiting for more than 20 minutes, the AP is still in same mode
  13. SO, I connected all the 3 APs to the switch
  14. 2 APs in Recover.Me mode the hard reset AP is in Configure.Me mode
  15. So, finally, I connected the ethernet cable from Router to the Switch
  16. Magic! All the 3 APs got auto configured and they got configured as per the old configurations. Including, the WLAN names and passwords
  17. I got into the Unleashed app but the Switch is requiring authentication
  18. I entered the username and password I set in step 5 but it said authentication failed
  19. I consoled into the Switch and tried to authenticate but failed
  20. Finally, was able to authenticate using the default username and password
  21. Switch asked me to change the password
  22. Finally, was able to authenticate using the new password and Switch status is good in the Unleashed app

This concludes the process.

I could have made the process complete sooner if I connect the router to the switch first and then see how things are going from there.

Also, confusing part for me is how the Switch reset back to factory mode and was unable to see status in the Unleashed app.

View solution in original post


New Contributor II

Here is the errors I see in the console after booting


PS 1, Internal Power supply detected.
PS 1, Internal Power supply is up.
PoE: Stack unit 1 PS 1, Internal Power supply with 62000 mwatts capacity is up
PoE Info: Adding new 54V capacity of 62000 mW, total capacity is 62000, total free capacity is 62000
PoE Info: PoE module 1 of Unit 1 on ports 1/1/1 to 1/1/8 detected. Initializing....
2000 log entries of PoE Event Trace Log Buffer is allocated on unit 1 for unit 1
PoE Event Trace Logging enabled for unit 1
PoE Error: Failed Devices Bitmap on PoE module:1, numDev:1.
Resetting module in slot 1 again to recover from dev fault
PoE Info: Hard Resetting in slot 1....
PoE Info: Resetting module in slot 1....completed.
PoE Error: Failed Devices Bitmap on PoE module:1, numDev:1.
PoE Severe Error: Hardware Fault with ports 1/1/1 to 1/1/8. Remove PDs and then configure "no inline power" on these ports.
PoE Info: PoE module 1 of Unit 1 initialization is done.  

Hi @chai_999 

Thank you for contacting Lennar Home Community.

Hope you are doing well!!!

Thank you for the detailed information you shared,

As per the case description, I could understand that one of the APs is not working. 

Could you please let us know how many APs are connected to your Switch? And is only one AP is affected?


Also, could you please let us know?

1. Was this working before or is it a new installation? If it worked before, was there any power outage before you started facing this issue?

2. On your switch while it's plugged into the outlet, do you see any lights on? (Amber or green) Please let us know which lights are on. (Please refer to the below picture and share a picture of the same)

As you have console access, please perform the below commands, and send us the output for the same.

Note: Hit Enter to accept each command 


show version
show inline power 
show inline power detail 


Before uploading the photos please login to the RUCKUS account and you can upload the image.

Please help us with pictures of your ICX-7150-C12P Switch showing the status of the lights. Also, light the status of Access Points.

Please help us with the above queries to assist you further. And let us know if you have any queries in this regard.

Thank you again for your patience.


Best regards,

Imran Sanadi

Lennar Home Community.


The switch is ICX 7150-C08P. There are 3 APs connected to the switch. 

Of the 3 APs, based on this document 

  • 1 AP is not getting any power. No lights are on.
  • 1 AP has PWR flashing green and CTL solid green and no other lights.
  • 1 AP has PWR flashing green and CTL flashing green (slow); meaning Network problem, cannot contact unleashed master.

System worked before and there was a power outage.

Here is the picture of the switch. The STAT light is green, SYST light is green and PWR light is green.20230409_121913_crop.jpg


New Contributor II

Please find attached the output of the commands 

show version

ICX7150-C08P Switch>enable
No password has been assigned yet...
ICX7150-C08P Switch#show version
Copyright (c) Ruckus Networks, Inc. All rights reserved.
UNIT 1: compiled on Jun 6 2019 at 20:57:00 labeled as SPS08091
(28774816 bytes) from Primary SPS08091.bin (UFI)
SW: Version 08.0.91T211
Compressed Primary Boot Code size = 786944, Version:10.1.16T225 (mnz10116)
Compiled on Sat May 25 10:09:26 2019

HW: ICX7150-C08-POE
UNIT 1: SL 1: ICX7150-C08-2X1G POE 8-port Management Module
Serial #:FMF3217R017
Software Package: BASE_SOFT_PACKAGE
P-ASIC 0: type B160, rev 11 Chip BCM56160_B0
UNIT 1: SL 2: ICX7150-2x1GF 2-port 2G Module
1000 MHz ARM processor ARMv7 88 MHz bus
8192 KB boot flash memory
2048 MB code flash memory
1024 MB DRAM
STACKID 1 system uptime is 2 minute(s) 8 second(s)
The system started at 00:01:07 GMT+00 Thu Jan 01 1970

The system : started=cold start

show inline powershow inline power.png

show inline power

ICX7150-C08P Switch#show inline power

Power Capacity: Total is 62000 mWatts. Current Free is 62000 mWatts.

Power Allocations: Requests Honored 17 times

Port Admin Oper ---Power(mWatts)--- PD Type PD Class Pri Fault/
State State Consumed Allocated Error
1/1/1 On Off 0 0 n/a n/a 3 internal h/w fault
1/1/2 On Off 0 0 n/a n/a 3 internal h/w fault
1/1/3 On Off 0 0 n/a n/a 3 n/a
1/1/4 On Off 0 0 n/a n/a 3 internal h/w fault
1/1/5 On Non-PD 0 0 n/a n/a 3 n/a
1/1/6 On Non-PD 0 0 n/a n/a 3 n/a
1/1/7 On Off 0 0 n/a n/a 3 internal h/w fault
1/1/8 On Off 0 0 n/a n/a 3 internal h/w fault
Total 0 0

show inline power detail

ICX7150-C08P Switch#show inline power detail

Power Supply Data On unit 1:

Power Supply Data:

Power Supply #1:
Max Curr: 1.1 Amps
Voltage: 54.0 Volts
Capacity: 62 Watts
PoePower: 62 Watts

POE Details Info. On Unit 1 :

General PoE Data:

02.1.1 Build 002


Cumulative Port State Data:

#Ports #Ports #Ports #Ports #Ports #Ports #Ports
Admin-On Admin-Off Oper-On Oper-Off Off-Denied Off-No-PD Off-Fault
8 0 0 8 0 5 5

Cumulative Port Power Data:

#Ports #Ports #Ports Power Power
Pri: 1 Pri: 2 Pri: 3 Consumption Allocation
0 0 8 0.000 W 0.000 W