Showing results for 
Search instead for 
Did you mean: 

ICX 7150 stuck in boot mode and non responsive

New Contributor


My ICX 7150 switch that came with my Lennar Home is stuck in boot mode after a power outage. I have an iMac computer and have followed the instructions for a reinstalling the drivers and software. When connected to the computer via USB to C cord and ethernet cable it does not even detect my ruckus switch. My unit is completely bricked and unresponsive. Please advise for further steps to resolve issue. Thanks.



Hi @Drewshreeve1

Make sure the cable is actually connected to the ICX-7150-C12P ( Switch ) In one of the 12 ports in the middle



Make sure the cable is in good condition so that both ends and connectors look good.

Note : you will see a light come on when a device is connected via Ethernet on 1 of the 12 ports available.

Here I will leave a short guide how to connect the devices properly : 

Most common Setups for Lennar homes users

Please check SYST and power the lights' status of the ICX7150 Switch, describe those lights for us first.

Also let me add more detail to understand the LED lights of your Access points. 

R510 LED lights

To solve the issue, you need to get access via console, using two connections one is for console access using the USB to type C cable (the USB will be connected on your computer and the type C on your ICX7150 Switch) now the second connection will be an Ethernet cable from your computer to the out-of-band port on your ICX 7150 Switch) don't worry the next guide explains the port locations and there are pictures about it, however I will advise performing a hard factory reset first, let me add the steps.

1:Factory reset:

  1. Remove power from the switch.
  2. Press and hold the Reset button while applying power to the switch.
  3. After all the system LEDs flash amber, release the Reset button.

When all the system LEDs blink green, all the configuration data are erased and the switch is returned to its factory configuration. When all the system LEDs are solid green, the erase process is complete and the system reloads. Once reloaded and the SYST LED is steady green, the factory reset is complete.


2:If the Switch is not responding to the factory reset, you need to perform the software recovery process,

Please read the guide carefully before start the steps.


How to perform a Software recovery on an ICX7150 switch

Ruckus ICX Recovery tutorial video

Best regards,


Lennar Home Community



Hi @Drewshreeve1

The first step is to try the factory reset,  then the Software recovery and finally perform the upgradation to the code 08095g UFI.

Please share the screenshot if the error while you are performing the software recovery process, so we can assist you.

Best regards,


Lennar Home Community

I have tried the factory reset many times and the lights flash amber over and over. After attempting the reset I have tried to do the software recovery, per your copy/pasted instructions. My computer does not even detect that the switch is even connected. I posted a screen shot earlier in this thread of my usb connections on my iMac within the computer settings….and the ICX 7150 switch does not appear. 

My device is still under warranty. I am the original owner and purchased it with my new home. I have gone above and beyond to attempt to resolve and fix the switch. Can I please be provided with a new replacement? Thank you.