Showing results for 
Search instead for 
Did you mean: 

I had power fluctuations few times and switch isn't working properly since then (very slow & drops)

New Contributor

I had power trips and fluctuations yesterday 4-5 times. Since then switch is not working properly. Internet is very slow and connection drops intermittently.  Tried restarting modem, router and switch no use still the same.


My setup : Modem -> Wifi Router -> Ruckus switch -> zoning points one in each floor.

Any help is much appreciated!!


Hi @rahulmandava 


Thank you for the response and the information you shared. 

This issue is because your switch is running on the Routing code (SPR). The Switch should run on the Switching code (SPS) to avoid these issues for Lennar home users. Due to a power outage/power spike, the Switch boots up on the other partition which may be running on a ‘Routing Code’ results in causing this issue.

As I can see from the output you shared, your Switch is booted up on the secondary partition which is running on Routing code (SPR) as highlighted in the below screenshot. 

Please Enter the below commands in CLI to fix this issue:

Note: Hit Enter to accept each command 


copy flash flash secondary 

boot system flash secondary yes 



ICX7150-24P Router>enable (hit enter to accept the command) 
ICX7150-24P Router#copy flash flash secondary (hit enter to accept the command and wait: until the flash finished) 
ICX7150-24P Router#boot system flash secondary yes (hit enter to accept the command: the switch will reboot)

Please let me know if you have any queries in this regard.

NOTE: Please feel free to mark the post as ACCEPTED SOLUTIONS if your issue gets resolved.

Thank you again for your patience and understanding.


Best regards,

Imran Sanadi

RUCKUS Lennar Home Community.

View solution in original post


I was able to login into switch now via IP Address login from browser. I don't see anything called firmware, but I do see this image version : (SW: Version 08.0.90dT213). Let me know if that is not the right one and / or if you need any information to further look into the issue ?

I do see few command options as well when I logged in, is there anything that I can run and see if the issue gets resolved ?

RUCKUS Team Member

Hi Rahulmandava

It looks like your Switch (ICX7150 Switch) may be booting from the secondary partition ( Note: Secondary partition contains the routing code) which is causing the bad connectivity issues. This could happen after multiple power outages, please follow up the next guide.

How to Fix Routing code issues on Lennar Home users via Web GUI.

How to Fix Routing code issues on Lennar Home users via CLI

Guide#1 for CLI:

Guide#2 for CLI:

Note: if you have access to the Unleashed Dashboard and the Switch can be seen from there, it may look like the following image, ICX7150-C12-Router instead of ICX7150-C12-Switch, now before starting the steps of the guide, I will advise you to cable the computer directly to the Switch, since you will have a better connectivity than if you connect via wireless.

After fixing the issue of the Switch booting from the wrong partition, please perform an upgrade to the code 08095g UFI and upgrade both partitions primary and secondary with the switching code file named SPS08095gufi.bin, take into consideration that is the Switch is running a code lower than 08080 you need to upgrade twice, from the code you are to 08080f and then the recommended code 08095g UFI.

How to Upgrade a Switch ICX-7150-C12P using a USB flash drive


How to upgrade a Switch ICX7150-C12P via TFTP


Upgrade a switch via Web GUI (ICX7150 Switch)


Please try the most common username and passwords ( This is key sensitive so please include capital letters )

Username:admin password: Ruckus!

Username:admin password: Ruckus1

Username:admin password: Lennar

Username:super password: sp-admin

Admin usernames and passwords for the Ruckus Wi-Fi Access Points/Switch for Lennar home users


Deepu Sekar

Hi Deepu, none of the links you shared are working. I get a page not found error.

Hi Deepu, I have tried the option via Web GUI. Still it didn't resolve the issue. Could you please help me with the next steps?

RUCKUS Team Member

Hi Rahulmandava

Could you please check the above links now , I have verified it which is working fine now .

Regards ,

Deepu Sekar