Showing results for 
Search instead for 
Did you mean: 

I had power fluctuations few times and switch isn't working properly since then (very slow & drops)

New Contributor

I had power trips and fluctuations yesterday 4-5 times. Since then switch is not working properly. Internet is very slow and connection drops intermittently.  Tried restarting modem, router and switch no use still the same.


My setup : Modem -> Wifi Router -> Ruckus switch -> zoning points one in each floor.

Any help is much appreciated!!


Hi @rahulmandava 


Thank you for the response and the information you shared. 

This issue is because your switch is running on the Routing code (SPR). The Switch should run on the Switching code (SPS) to avoid these issues for Lennar home users. Due to a power outage/power spike, the Switch boots up on the other partition which may be running on a ‘Routing Code’ results in causing this issue.

As I can see from the output you shared, your Switch is booted up on the secondary partition which is running on Routing code (SPR) as highlighted in the below screenshot. 

Please Enter the below commands in CLI to fix this issue:

Note: Hit Enter to accept each command 


copy flash flash secondary 

boot system flash secondary yes 



ICX7150-24P Router>enable (hit enter to accept the command) 
ICX7150-24P Router#copy flash flash secondary (hit enter to accept the command and wait: until the flash finished) 
ICX7150-24P Router#boot system flash secondary yes (hit enter to accept the command: the switch will reboot)

Please let me know if you have any queries in this regard.

NOTE: Please feel free to mark the post as ACCEPTED SOLUTIONS if your issue gets resolved.

Thank you again for your patience and understanding.


Best regards,

Imran Sanadi

RUCKUS Lennar Home Community.

View solution in original post


RUCKUS Team Member

Hi ,


I understand that there was a power fluctuations few times and after that switch is slow and drop pakets

Please help us with the below information

-Do you see any amber light indication on the switch ?
-what is the current firmware version ?
-check if there is a CPU spike on the switch
#Show cpu(5 times)
#Show cpu task(3 times)

-share us with the above output .

Regards ,

Deepu Sekar

Hi Deepu,

Thanks for getting back to me. I am not seeing any amber light on switch, just the regular light that we always see. 

Regarding the firmware and cpu spike info, I am not sure how to check those. I am not able to connect or login to switch. Could you please help me with the steps on how I can get there ? or any other ways to resolve the issue ?

RUCKUS Team Member

Hi Rahulmandava ,

Than you for your response , I understand that . you are  not able to connect or login to switch. 

-So you are unable to login after the power fluctuations ?

-Could you please help us with the switch model number so that i will help you to access the switch .

Regards ,

Deepu Sekar


I haven't tried to login in the recent past. But when I tried to once I got this issue, I am unable to either login via UI interface/Unleash app or connect via putty using IP address. 

Switch model number is : ICX 7150-C12P