Showing results for 
Search instead for 
Did you mean: 

Check firmware version and update ICX7150-C12P?

New Contributor

Hello - I purchased my Lennar home in April 2020, and have an ICX7150-C12P switch that recently wasn't booting and I needed to reset. It seems to be working now, but when I was reading various forums trying to troubleshoot, I did notice recommendations to update firmware on the switch.

When my switch finally restarted after the rest, I was able to use the Unleashed app to check and update firmware but I think that's only for the R510 access points? When I attempt to login to the switch by going to its IP address in my web browser and using what I thought was the correct login and password, it's not working. 

Should this login (directly to the switch's IP address) use the same credentials as used in the Unleashed app? If not, how would I find out what the correct login info is? (I thought perhaps due to the reset the login reverted to the original provided by Lennar, but that didn't work either). 

Alternatively, is there another way to see which firmware version is on my switch and update it, without needing a cable (which the installer didn't leave here) or messing around with a command-line? Thanks



Hi @AK 

Yes, the recommended version is 08095g UFI, however let me provide you the bundle of possibles credentials to gain access, if you gain access you can confirm what will be the version from the web, but I will remove to perform the upgrade via USB, like you know the IP address will be easy to gain access via SSH or telnet, which I will add the guide too.


Note: Please read the guides carefully before start the troubleshooting.

Usernames:           Passwords:

admin                    sp-admin

super                     Lennar








How to remotely access to 'ICX 7150-12P' or 'access points' "Network devices"


How to Access an ICX Switch remotely via SSH or Telnet, using a Windows computer


How to Upgrade a Switch ICX-7150-C12P using a USB flash drive

How to upgrade a Switch ICX7150-C12P via TFTP



Best regards,

Yarenis Hernández.

Technical Support Engineer | L2 TAC Wired | Lennar Home community


New Contributor

Thank you, Yarenis. I will check out these help docs, but two things related to your original answer:

  • I use a Mac, not a PC - I assume the apps used and the instructions change, in that case? (I'm also not familiar with "SSH" or "telnet" or "command line" work so I hope the Mac instructions are less technically complicated - the PC instructions were not really understandable for me 🙂 
  • I know that I changed the login and password from what it originally was, and I also know what the original one was for my home (admin/Lennar). When I reset the switch, if it reverted to the original shouldn't it have reverted to that? 

Also, this morning there was a short power outage, and when the power came back on, the switch again didn't reboot (had solid amber SYST light and solid green PWR light). I tried to reset it again. That worked yesterday but today something different happened. I held down the reset button after plugging the switch back in until the lights started flashing, but the lights never stopped flashing. After about 10 minutes (with the lights still flashing), the switch seemed to power on the WAPs and the wifi network came back, but the lights are still flashing on the switch too. I'm not sure if that signifies anything....

Thank you for your help. 

Hi @ AK


For MAC computers, you don't require applications to access, because the same terminal APP will work for Telnet, SSH, or console access, however like you have a power outage, seems the Switch is not stuck in boot mode, so a factory reset must be performed if the Switch stills not responding a software recovery will be the next step, so in order to fix it try first the factory if not, you need to get access via console, using two connections one is for console access using the USB to type C cable (the USB will be connected on your computer and the type C on your ICX7150 Switch) now the second connection will be an Ethernet cable from your computer to the out-of-band port on your ICX 7150 Switch) don't worry the next guide explains the port locations and there are pictures about it. 



Note: Please read the guides carefully before starting the troubleshooting.



1:Factory reset the Switch:


  1. Remove power from the switch.
  2. Press and hold the Reset button while applying power to the switch.
  3. After all the system LEDs flash amber, release the Reset button.

When all the system LEDs blink green, all the configuration data are erased and the switch is returned to its factory configuration. When all the system LEDs are solid green, the erase process is complete and the system reloads. Once reloaded and the SYST LED is steady green, the factory reset is complete.






2:If the Switch is still stuck in boot mode(SYS LED light Amber)perform the software recovery.


How to perform a Software recovery on an ICX7150 switch

Ruckus ICX Recovery Load boot code from boot monitor



Best regards,

Yarenis Hernández.

Technical Support Engineer | L2 TAC Wired | Lennar Home Community

New Contributor

Hello Yarenis - 

I performed the factory reset (again), following the steps you included and as demonstrated in the video


What I now see is a steady green power light and all other lights continue to blink as they did since I released the reset button. It looks like at 1:25-1:30 timestamp in the video linked above, with all the lights blinking amber, for hours.

I tried the factory reset several times to resolve this, but with the same results. The factory reset doesn't seem to complete - the device just sits with all the lights blinking amber.  The switch is not on the network and has no IP address.

If all lights are blinking amber, is this "stuck in boot mode"? The SYS LED light is not steady amber (as you describe) but is blinking along with all the other lights. 

Is my next step to do the software recovery? If so, I want to be sure I use the correct firmware. 

This document that you provided talks about using version 08090k, but this document and this video mention that in order to go from "non-UFI 8070 version to 8095h UFI version," I would need to do an intermediate version 8080f. 

I don't know what version my switch has now because it will no longer boot at all, so I wasn't sure if I can use the 08090k mentioned in the "software recovery" help document, or if I have to do 8080f first and then 8095h?

Finally, the documentation mentions that to do the software recovery I need an ethernet cable to connect between my laptop and the switch (which I have), and a "console cable" that is USB-A on one end and USB-C on the other end. I am not having any luck finding a cable called a "console cable" on Amazon that is USB A to USB C....all of those cables are described as "charging cables."

Will a charging cable work for this purpose? All of the "console cables" I see are USB A to RJ45, not USB C. Do you have a link to an appropriate cable on Amazon or some other site? (from reading other posts, I think there originally was a console cable in the box with the switch, but the Lennar installer didn't leave the box or the cable here).