Showing results for 
Search instead for 
Did you mean: 

broadcom cards connection problem

New Contributor

My clients (mainly DELL XPS) with Win10 and  Broadcom wifi cards (DellWifi 1560, 1820A) reported random  2-3 times a day rejoins to AP. They was connected to R700 AP with ZD1100 . So we do upgrade to latest ZD1100 . But now they are completly out - they cant connect to EAP 802.1x AES network anymore. Windows drivers was not changed but they cant connect. changing drivers up/down versions doesnt help too.

Clients with XPS but other vendor cards (intel,killer...) are ok.  

On internet there are lot of issues with win10 and broadcom cards, but with previous  ZD fw it worked (with disjoins but worked ).
Is there something specific issues/recommendation for Broadcom cards ?

Thank you for any advice for  specific broadcom tuning my ZD. 

New Contributor
no one with this kind problem ? 

reverting back fw to restored connectivity for broadcom cards. 

Thanks for the tip Marian.  You might want to contact TS to take a deeper look if a bug is needed.

New Contributor
Hi Marian

I had a similar issue with Dell XPSs in the last couple of days when I enabled 802.11k and 802.11r to improve roaming.  It turns out that any Broadcom WiFi devices (including all the XPSs) stopped connecting to the network.
It's the 802.11r part that's responsible here, toggling it back off allowed them to re-connect.

This is also on an 802.1x network, we're currently running build 22 on R510/ZD1200.

Does that fit the same scenario in respect of the 802.11r with Broadcom WiFi?

New Contributor
This is the problem I am experiencing with a Broadcom-based Dell 1820A Wi-Fi card, ZD1200 on build 42.
Was there some resolution to this issue, other than turning of 802.11r?