Showing results for 
Search instead for 
Did you mean: 

Two Masters and No Members

New Contributor II

Ruckus R500
Unleashed firmware

I have two R500 and each shows as Master under Access Points (i.e., two masters and no members). I have attempted the following without success to have a single Master and rest as members:

  • both R500s are on same network subnet and can ping each other
  • tried set both APs with static IP addresses or DHCP
  • tried factory reset by pushing reset button with paper clip for 10+ seconds and from rkscli "set factory" command
  • tried to force either AP as member from rkscli "set election role 1". This did not work. Able to ping and ssh but only shows "Building the Unleashed Network. It may take a few minutes." on browser infinitely.
  • tried both settings in System>System Info>Preferred Master to No Preference or selecting it as master
  • checked both AP country code are the same "United States"

Note, did not have this problem before. It worked for more than two years until recently. Not sure what caused it maybe a power outage. First time noticed problem after seeing "Disconnected 1" under Access Points. So clicked remove and rebooted. After rebooting, both becomes Master.


RUCKUS Team Member

Hi @thomas_hong,

Thank you for reaching out to RUCKUS Support via FORUM.

Please could you try manually adding member AP to master, shared commands for your reference:


Let us know how it goes.


Vasanth Edward

Hi Vasanth,

Still not working after executing commands you posted. See attached image:

R500-2 disconnected.png

Best Regards,


Screenshot of R500 I prefer to be the master AP.R500-1 master.png

Hello @thomas_hong 

Could you please provide the output of the below command from all the three APs.

get version

Also please run the below command on the other two R500 APs which you want them to join the controller as member AP.

rkscli: set election role 0

If you want to fix AP election role as Member, you can input  “set election role 0”