Showing results for 
Search instead for 
Did you mean: 

SpeedFlex Broken with Unleashed?

New Contributor

Hi, I manage several Ruckus networks both on ZD and Unleashed, but going to the simplest example, an Unleashed network at my house with ... for this example ... just two APs ... an R750 and an H550.  In running SpeedFlex, enabled through the Unleashed admin, I get 900+ Mbits down ... as expected.  But, I get as little as 1 Mbits (yes, 1) up.

This was baffling to me as if the performance was truly that bad, we'd see all kinds of issues in real use. (Yes, I made sure that I was on the closest access point, tested multiple times, etc...)

So, I set up Open Speed Test on my Synology to test bandwidth on the LAN -- a more real world test, in my mind as it tested not just the Wi-Fi, but the LAN as well.  The results ... close to 1 Gbps both up and down.

It appears to me that SpeedFlex, at least in regards to Unleashed ... is just broken. Anyone else experiencing the same thing?


RUCKUS Team Member

Hi @neil_ticktin_io 

I just had a check in lab with the below setup
1. R750 and H550 on, with R750 being Master.
2. Used client : Android and iPhone 11 pro.
3. Downloaded Speedflex from Playstore and Apple store.
4, Clients were about 4 meters away from AP.
5. Tested client when connected to R750 and H550.
6. Tried on both 2.4 Ghz and 5 Ghz.
7. Tried both TCP and UDP test.
8. WPA2 SSID with default settings

In all the scenarios, the Uplink was never 1Mbps 
Only when the client was on 2.4 Ghz, the speed was showing Uplink 3.5 Mbps and Downlink 43 Mbps.. Probably because of the lab environment with lots of interference.

Below are the results:
2.4 Ghz:


5 Ghz:




Can you try the below steps:
1. Ensure that the Speed flex app is latest one.
2. Ensure that the client is connected to the 5 Ghz.

If these 2 steps are followed, then please open a support case so that we can look into the issue.