cancel
Showing results for 
Search instead for 
Did you mean: 

Warning - upgrade from 5.2.2.0.1562 to 6.1.0.0.935 breaks cluster

mark_pledl
New Contributor III

Dear Ruckus Crowd,

please be careful when you try to upgrade from 5.2.2.0.1562 aka MR2 release to 6.1.0.0.935. 

it might break your cluster and you will have a bad day if you do not have a exported cluster backup or snapshot.

Reproduced with vSZ-E. Testing other models tomorrow.

Setup clean vSZ with 5.2.2.0.1562 or upgrade one to 5.2.2.0.1562. Than make a backup and upgrade to 6.1.0.0.935. Upgrade process will fail after migrating database in step preparing system with cluster operation failed.

You will be able to get access to UI but after restart no cluster process will start any more..

More details will follow. 

Best regard,

Mark

PS: kudos to my colleague who found that out the hard way.. because APs for project changed to R350s and he needed to upgrade…

2 ACCEPTED SOLUTIONS

Hi Mark,

I have replicated this issue in the lab as well and had a quick discussion with the engineering on this issue. As per engineering the 5.2.2.0.1562 to 6.1.0.0.935 is not a supported upgrade path as the release the 5.2.2.0.1562 MR2 was targeted for 6.1.1(Releasing in next couple of months). The 5.2.2.0.1562 MR2 have changes in the database and binaries as per v/SZ 6.1.1, moreover 5.2.2MR2 have major bug fixes which cannot be ported to 6.1 which was released back in Dec 2021. The Supported upgrade path from v/SZ 5.2.2 to 6.1 will be 5.2.2.0.317 >> 6.1.0.0.935 or 5.2.2.0.1161 >> 6.1.0.0.935.

We acknowledge that we need to update the 6.1 Release notes with the correct upgrade path limitations and I have notified our Technical Publications Team to make this change at the earliest. Once again, thank you for bringing this issue to our attention through forums and we sincerely apologize for the inconvenience caused to you.

Regards,
Ankush

 

View solution in original post

Ankush_Chandan
Internal Employee

To close loop on this Topic, we have updated the 6.1.0 Release notes and Upgrade Guide with supported upgraded path. In addition to that, we have also updated the 5.2.2.0.1562 Release Notes with a Warning on "No Support to upgrade to 6.1.0 Release". Here are the reference Documents:

SmartZone 6.1.0 (GA) Upgrade Guide

https://support.ruckuswireless.com/documents/4057

 

SmartZone 6.1.0.0.935 (GA) Release Notes

https://support.ruckuswireless.com/documents/4058

 

SmartZone 5.2.2 (LT-GD MR 2) Release Notes

https://support.ruckuswireless.com/documents/4207

Regards,

Ankush

View solution in original post

15 REPLIES 15

mark_pledl
New Contributor III

 

Attached 2 screenshots.

vSZ-H fails also upgradevSZ-H fails also upgrade

Upgrade 5.2.2.0.1562 to 6.1.0.0.935Upgrade 5.2.2.0.1562 to 6.1.0.0.935


After restart…After restart…

mark_pledl
New Contributor III

I can confirm the bug for vSZ-H too.

quite possible also SZ104/SZ124/SZ144 und SZ300 might have same issue - as it seems to be some general thing.

Br,

Mark.

 

mark_pledl
New Contributor III

I just tested in lab rollback when error message above is happening.

Option 1: Node(s) got not restarted and you click the link and get back to gui: You still can rollback last cluster backup succesful.

Option 2: You restarted the node(s) in panic... services do not come up you need to restore each node from cli.

login
-> restore 
-> select desired restore point
-> check node after reboot
-> if you have a cluster with more then one node - do it on the other nodes in same way too as the cli is limited to single node (correct me if I am wrong) and GUI will do whole cluster.

Br,

Mark.

 

Thank you Mark for bringing this to our attention. We have one such issue reported during a recent migration from 5.2.2 to 6.1 and yours is the 2nd case. We will work internally on the lab replication and if this issue is confirmed, we will report it to the engineering team.

It will be great if you could log a support ticket if you haven't already for the reference.

Regards,

-Ankush