Showing results for 
Search instead for 
Did you mean: 

IPTV with H500 LAN Port Stuck when TV channels changes frequently by the user

We are testing IPTV with H500 AP. AP is powered through POE switch. IPTV STB is connected to AP via LAN port. 
Normally TV works without issues. But once we change the channels it get stuck. AP traffic is backhauled locally without using any tunnels. 

Any idea what would happen on this? 


Esteemed Contributor II
Hello Pamuditha,

   In the case where your IPtv Set Top Boxes are connected thru a LAN Ethernet port,
you want to tell the AP not to listen/answer (snoop) your multicast IGMP client traffic,
and it should be faster and follow the TV channel changes.  I don't know which of your
H500 ports your STBs connect to, but here is syntax you can use if you SSH into your
APs.  You want to disable igmp snooping, and directed-multicast (use straight UDP),
and can assume version compatibility.

You can SSH into an AP CLI using putty application and run the following commands.
        set qos igmp [enable|disable]
                 -- Sets the state of IGMP Snooping for the specified interface
       set qos directed multicast [enable|disable]
                 -- Sets the state of egress packet processing for the specified interface

        set qos igmp_query [v2|v3] [enable|disable]
                 -- Sets IGMP General Query version for IGMP General Query Mechanism
ifname : interface name can be wlan0 / eth1 / eth2.

Use the "get eth" command to determine which eth0, eth1, eth2 of your H500 has the STB
then issue these two commands:

set qos ethX igmp disable
set qos ethX directed multicast disable


If you manage your H500s by a ZoneDirector, you can apply commands remotely.  These
will affect ALL connected APs however, so ok if all H500s and if the EthX port they're using
don't exist on the other models, ie Eth3 or Eth4.

You would SSH to your ZoneDirector, and then issue these AP commands.

ruckus> enable
ruckus# debug
ruckus(debug)# remote_ap_cli -A "set qos ethX directed mutlicast disable"
ruckus(debug)# remote_ap_cli -A "set qos ethX igmp disable"
( where EthX is the LAN port your H500's have STBs connected to)

ruckus(debug)# quit

Good luck and please let us know your test results.

How would i go about saving these config changes on AP's managed by a Zone director?



Hi Michael, 

STB is connected to H500 eth1 port, which can power STB as well with POE out. 
I tried these commands with eth1 and no success. 
These APs are managed by vSZ and tried the same with standalone mode as well. But still the result is same. 

Do you think applying these commands on the wan interface would help.?
As we understood, some of the responses we get from multicast servers doesn't go through eth0 (wan interface ) to eth1 (STB interface).
Once TV is stuck, unk-drop counter is also increasing. 
Also this issue occurs only we change channels quickly.


New Contributor III
Hi Pamuditha, 

I just expierenced the same issue at one of my sites.

Disabled the direct multicast on both the eth0 the eth1. 

you will also need to disable the igmp-snooping on both interfaces. 

Then you need to make sure that you have forced fast-leave / port-fast configured on the switch interface the AP is connected to. 

What Switching are you using?

Are you using IGMP v2 for multicasting?

I hope this helps.