Showing results for 
Search instead for 
Did you mean: 

We don’t have any power at the R510 access point switches. I have tried resetting the switches and

New Contributor III

We have no power at the 2 R510 switches in our Lennar home, this happened after a power outage.there is power at the main hub and we have tv, phone and internet. I have tried to reset both switches, but none of the lights on the switch box light up. I think the switches were fried after the power outage. Any suggestions would be helpful but please consider any advice needs to be in simple terms please



Hi Mike,

Can you please follow below detailed video to check if the connected switch is powered on and if F/D is done :

Best Regards


I watched the video several times prior to posting my problem. I’m not getting any power indicator lights on the switch at all, I have tried several times to reset the switch 

You will need to reach out to support over and share the serial of these two R510 units to see if these can be replaced. FYI these are not termed switches but Access points "R510" just to clear the misunderstanding. 

Best Regards


Thank you for the correct terminology and your response. I will go to Ruckus support but I thought they aren’t helping anyone who has a Lennar home. They directed me to this support group. I will try Ruckus again.