Showing results for 
Search instead for 
Did you mean: 

Unable to follow steps in Software Recovery Instructions

New Contributor

I am following the instructions in and when I get to the device manager, I do not see any COM# listed under Ports (COM & LPT). I tried adding legacy hardware in device manager and I get error code 34.  I am unable to run putty, as I get an error. I think something may be wrong with the usb-c port on the switch, as I have tried several different cables. Other usbs connect to my laptop without issue. 


Hi @liljazz2007 


Thank you for the response and for sharing the requested information.

Based on the troubleshooting done, you confirmed, and we saw that after the reset, booting up the Switch, and trying the software recovery process multiple times, the failure persists with both console ports not responding. This Switch unit Should be RMA (Return Merchandise Authorization) in simple words replacing it.

Feel free to contact us via chat, comment you already have a post, copy the link from the post (URL), and paste it into the chat to start the unit replacement.

Please follow the steps as shown in the below example:

As shown in the below picture, copy the link and share it via chat from the link provided below:

The below link is to contact us by chat (only)

Please let me know if you have any queries in this regard.

Thank you again and we appreciate your patience.


Best regards,

Imran Sanadi

RUCKUS Lennar Home Community.

View solution in original post


Thank you. I just submitted the RMA. 

Hi @liljazz2007 

Thank you for the response and the update.

We appreciate your time and patience on this case.

Thank you again for contacting RUCKUS Lennar Home Community and feel free to contact us for future queries.

Have a great day ahead!!!


Best regards,

Imran Sanadi

RUCKUS Lennar Home Community.

New Contributor


I have been in the same situation as @liljazz2007 and other frustrated Lennar Home-Ruckus users 

I can't access the switch console. I have performed the software recovery step guide carefully and patiently for 17 times.

The Pc reads COM# but when I start performing the Software recovery process with Putty or Mobax both apps show connection error with the port of the Switch Console and the promt ICX7150-12 Router> ICX7150-24P Switch> does not initiate. 

All USB and RJ45 ports are working fine they have been tested. as I said I have been doing this process carefully and patiently for 17 times

Hi @FortunatoX 


Thank you for contacting RUCKUS Lennar Home Community.

Hope you are doing well!

As you are getting ICX7150-12 Router Prompt, this is a different issue than this post and can be fixed easily.

As this case is raised by @liljazz2007 

To avoid confusion with posts, you can create your own post with the problem you're facing and a detailed description of the network issue and what you've done so that we can guide you properly.

Thank you again for understanding.


Best regards,

Imran Sanadi

RUCKUS Lennar Home Community.