Showing results for 
Search instead for 
Did you mean: 

Unable to follow steps in Software Recovery Instructions

New Contributor

I am following the instructions in and when I get to the device manager, I do not see any COM# listed under Ports (COM & LPT). I tried adding legacy hardware in device manager and I get error code 34.  I am unable to run putty, as I get an error. I think something may be wrong with the usb-c port on the switch, as I have tried several different cables. Other usbs connect to my laptop without issue. 


Hi @liljazz2007 


Thank you for the response and for sharing the requested information.

Based on the troubleshooting done, you confirmed, and we saw that after the reset, booting up the Switch, and trying the software recovery process multiple times, the failure persists with both console ports not responding. This Switch unit Should be RMA (Return Merchandise Authorization) in simple words replacing it.

Feel free to contact us via chat, comment you already have a post, copy the link from the post (URL), and paste it into the chat to start the unit replacement.

Please follow the steps as shown in the below example:

As shown in the below picture, copy the link and share it via chat from the link provided below:

The below link is to contact us by chat (only)

Please let me know if you have any queries in this regard.

Thank you again and we appreciate your patience.


Best regards,

Imran Sanadi

RUCKUS Lennar Home Community.

View solution in original post


Something is definitely wrong with the management port on this switch. 

Hi @liljazz2007 

Thank you for the response.

Apologies, the screenshot you shared is for a different case issue. However, sometimes before approving RMA we share steps and interact on private messages with the users to avoid unnecessary posts on the case. 

We have not tested with RJ45 to DB9 for software recovery process. However, you can give it a try as DB9 Serial ports converts it into An RJ45.

I would suggest you perform software recovery by unplugging all the cables attached to the Switch, except 2 Software recovery and a power cord.

If still you are getting the same result, I request you please download the MobaXterm app similar to Putty and perform the same operation once again there. (Please refer to the below screenshots)

Below is the link to download the MobaXterm application:


Please confirm and let me know if you have any queries in this regard.

Thank you again. We appreciate your patience and understanding. 


Best regards,

Imran Sanadi

RUCKUS Lennar Home Community.

I am still getting the same errors. What is the solution? Capture2.JPG

Hi @liljazz2007 


Thank you for the response and the information you shared.

Could you please share a screenshot of the current status of the Device Manager showing the COM ports when Switch is connected with the 2 software recovery cables to the laptop?

Thank you again for your patience and understanding.


Best regards,

Imran Sanadi

RUCKUS Lennar Home Community


You are failing to listen to what I am telling you. The usb-c port on this switch is not functioning properly. If it were, my laptop would pick it up, as it picks up every other usb device plugged into it. My laptop is not the issue, this switch is and Ruckus needs to replace it. I'm not sure why you all signed up to provide switches to Lennar if you were going to provide poor service. This has taken far too much of my time trying to resolve when I already told you the box is defective. I've even told you I've tried other laptops and the same is true. Please send me an RMA so this box can be replaced by Ruckus!