Showing results for 
Search instead for 
Did you mean: 

Sonos Sub Gen3 pairing issues with Arc and Ruckus Unleased

New Contributor


I have been reading a few articles about some of the default settings that Ruckus APs utilize and have been experiencing what appears to be a common problem for those with a similar setup to me where my Sonos Sub won't pair properly with the Arc (I get the Arc +? issue).  I proceeded to login to my master AP with Putty and change some config settings (disabled directed multicast, enabled spanning tree protocol).  I also went onto my router (tp-link wired) and enabled UPnP and IGNP Proxy, but I still get the same issue where my Sub won't stay paired with my Arc.  

Am I missing something? Should I reboot my router and my APs and try again?  My sub pairs with the Arc now (which normally it wouldn't even pair on first attempt) but it won't stay paired.  I saw another post where someone with other APs needed to also disable mcast on the ports for the specific AP model, but I tried that and CLI wouldn't let me change port settings for the R510.  Any other ideas or tips (wired ethernet is not an option)?




Hi @Awp23 

correct, because the Sub will be in the wirelessly connected.

Best regards,

Yarenis Hernández

Technical Support Engineer | L2 TAC Wired

New Contributor

Thanks, I'am able to access the CLI via Terminal. The only problem is that I can't get the "no dos directed-multicast" command to be recognized. Does the AP firmware need to be at least a specific version? I get the following: 

ruckus(config)# no qos directed-multicast

The command is either unrecognized or incomplete. To view a list of commands that you can run  from this context, type '?' or 'help'.


Is this setting specific to the one wifi connection, or does it also affect all other wifi connections beamed by the APs?


I ran the hep command and the "no dos" isn't on the list. Here is what is available:

no location-services <WORD>

                       Deletes an location server from the list of location servers.

  no aaa <WORD>        Deletes an AAA server from the list of AAA servers.

  no dhcp <WORD>       Deletes a new DHCP server from the list of DHCP servers.

  no ad-domainsvr      Deletes a AD domain service.

  no ap <MAC>          Deletes a device from the list of approved devices.

  no ap-group <WORD>   Deletes a device group from the list.

  no hotspot_redirect_https

                       Disables hotspot settings.

  no blocked-client <MAC>

                       Unblock a specified client.

  no l2acl <WORD>      Deletes an entry name from the L2 ACL.

  no l3acl <WORD>      Deletes an entry name from the L3/L4/IP ACL.

  no prece <WORD>      Deletes an entry from the Precedence Policy.

  no dvcpcy <WORD>     Deletes an entry from the Device Policy.

  no app-policy <WORD>

                       Deletes an entry from the Application Policy.

  no user-app-ip <name>

                       Deletes an User Defined Application.

  no user-app-port <name>

                       Deletes an User Defined Application.

  no whitelist <WORD>  Deletes an entry from the White List.

  no stp               Disables spanning tree protocol settings.

  no upnp              Disables UPnP settings.

  no wlan <WORD/NAME>  Deletes a WLAN service name.

  no wlan-group <WORD>

                       Deletes a WLAN group.

  no role <WORD>       Deletes a role entry.

  no user <WORD>       Deletes a user entry.

  no guest-access <WORD>

                       Delete a guest access service.

  no guest-access-force-https-redirection

                       Disables guest access force HTTPS redirection.

  no web-portal-force-https-redirection

                       Disables web portal force HTTPS redirection.

  no portal_auth-force-dns-server

                       Disables portal authentication force DNS server.

  no hotspot <WORD>    Deletes a hotspot entry.

  no alarm             Disables the alarm setting.

  no sms-server        Disables the SMS server setting.

  no usb-software <ID>

                       Deletes an USB Software Package from the list of USB Software Packages.

  no mdnsproxy <zd or ap>

                       Disables mdnsproxy(bonjour gateway) service.

  no mdnsproxyrule <Service-Name> <VLAN-From> <VLAN-To>

                       Delete Mdnsproxy rules

  no bonjour-policy <name>

                       delete a bonjour policy

  no bonjour-fencing <name>

                       delete a bonjour fencing

  no upload-debug      Disables the upload debug file setting.

Hi @Gordo_GT 

Please follow up the next example, important must be done from the master Access point, you can confirm which one is your master access point from the APP or the unleashed dashboard.


SSH al Master ap



ruckus(ap-mode)# set qos eth0 directed multicast disable

ruckus(ap-mode)# set qos eth1 directed multicast disable

ruckus(ap-mode)# set qos eth0 igmp disa

ruckus(ap-mode)# set qos eth1 igmp disa

ruckus(ap-mode)# set qos eth1 classification disa

ruckus(ap-mode)# set qos eth0 classification disa

ruckus(ap-mode)# quit


Best regards,

Yarenis Hernández

Technical Support Engineer | L2 TAC Wired

Thank you for your reply but I need a bit of clarification. Do I enter the above as a single command or in sequence? And where exactly do I start these commands? 

Here is how I enter/start: 

ssh (my ap username)@(my  IP address)


Please login: (my ap username)


Welcome to Ruckus Unleashed Network Command Line Interface

ruckus> en