Showing results for 
Search instead for 
Did you mean: 

Ruckus ICX 7150 C12P not connecting after power outage

New Contributor II

Hello @Yarenis and @Jayavidhya,

My problem looks similar to the one posted here. I was away from home yesterday but noticed that my Wi-Fi was down (no connection to Ring camera, indoor security cameras, thermostat, etc.). When I arrived home today, I saw that the two APs in my home were not working (no LEDs on) and the Ruckus switch had the SYST light amber and PWR light green. My wireless router is working fine. I was told by my neighbors that our power had gone out briefly the day before.

The first thing I attempted was a factory reset as instructed in other posts. To do this, I removed power from the switch, held the Reset button with a pin, and plugged in the power cord again. I held the Reset button for several seconds until all LEDs began to flash amber, then I let go. The LEDs flashed amber for more than 45 minutes, so I disconnected and reconnected power again. Currently it is back to the original status with amber SYST and green PWR.

Then I followed these instructions to attempt a software recovery. I ran into an issue with the connection between my computer and the switch's console port via ethernet cable. Here is what I see in the Device Manager for my ethernet connection. I checked using two different Windows computers and two different ethernet cables - all configurations gave the same error message, so I believe it's an issue with the switch and not the cable itself. 


If I attempt to continue in PuTTY, here's what I see: 


I am unable to continue past this point. I'd appreciate any help to resolve this issue as quickly as possible. Thank you very much.


EDIT at 9PM 11/25/23: I attempted to factory reset the switch again at 7:23PM. It is now 9:00PM (90 minutes later) and all LEDs except PWR are still blinking amber. 



Hi @sharonbelvi 


Thank you for the response and the information you shared.

Even after turning off the firewall if you see the same error. Please perform the next commands after this step you see in the below ‘not alive’ error.

Please perform the below commands.

“setenv image_name SPS08090k.bin”                                        (enter the correct image file name)

 “update_primary”                                                           (upload the image on the primary partition)

“setenv image_name SPS08090k.bin”                                        (enter the correct image file name)

“update_secondary”                                                           (upload the image on the secondary partition)

*Wait that loads the image and continue with the boot:

 “setenv uboot mnz10115.bin”                                                    (enter the correct boot file name)

 “update_uboot”                                                                      (upload the boot code)

 * Wait that loads the boot and continue with the Final command reset:

“reset”             (finally enter reset to reload the unit)

After performing the above commands please check if the SYST and PWR lights on the Switch turn green and let me know if you have any queries in this regard.

Thank you again for your patience and understanding.


Best regards,

Imran Sanadi

RUCKUS Lennar Home Community.

View solution in original post


RUCKUS Team Member

Hi Sharonbelvi

Thank you for reaching us

  • Could you please let me know if you are from Lennar Homes ?

Below is a link which you can refer that has more details about how to console to the switch. Could you please try the method in the below link and check if that helps resolving the problem.

How to console to the switch:


New Contributor II

Hello @Chandini ,

Thank you for your response. Yes, I am in a Lennar home. The Ruckus ICX switch came pre-installed when I bought the home in 2020.

Based on your instructions on how to console the switch, I can see that I was trying to use the COM# for the ethernet cable, but now I am correctly using the COM# for the USB-C serial connection. 

When I go back to the original instructions on performing a software recovery, I run into an error in the PuTTY window.

Here is my Upgrade folder with the correct files:


Here is my TFTP connection:


And my device manager showing that the serial connection is using COM4:


Here is my PuTTY setup:


And here is the result when I type the first command:


Thanks for your help,


New Contributor II

I noticed a typo in my command. I continued to follow the instructions but reached this stopping point where the ping failed and said "host is not alive".



Hi @sharonbelvi 


Thank you for contacting RUCKUS Lennar Home Community.

I hope you are doing well!!!

Thank you for the detailed information you shared.

As per the case description, I understand that your RUCKUS ICX-7150-C12P Switch isn’t working which is stuck in boot mode with Amber SYST and GREEN PWR.

As you are getting "host is not alive" error

Are you turning off the Windows firewall? If not, please turn off the Windows firewall and retry the software recovery process once again.

Please refer to the below link on how to turn off the Windows firewall:

When you turn off the firewall, please close the putty and restart it once again, restart the software recovery process from setenv IP configuration.

Please let me know if you are getting the same error or are stuck at any point in the software recovery process.

Thank you again for your patience and understanding.


Best regards,

Imran Sanadi

RUCKUS Lennar Home Community.