Showing results for 
Search instead for 
Did you mean: 

Request RMA for ICX 7150 switch

New Contributor

I'm not sure how this forum works.  I have the ICX 7150 switch that won't power up.  I've tried resetting and connecting my pc to the console using putty but I can't get the switch to power up.  I'd like to request an RMA.  I'm not able to load a picture.  I've included my pic.Picture of my device plugged into wallPicture of my device plugged into wall


New Contributor


I get this message when I click the CHAT tab on the right side of the screen.  I am logged into Rukus and I am not incognito.


Hi @DBialt83 


Please try using the below link and click chat now where you can start a chat or request for RMA.





Best regards,


Lennar Home Community

New Contributor

I still get the same message.  If I don't log in, I don't have a Chat Now tab and when I do, I get the error message from my last reply.  I am not incognito.  I do not know what private mode is.

This issue has taken a week so far and I've gotten nowhere.  I have a R510 access point that has never worked but I want to get this issue resolved first.