Showing results for 
Search instead for 
Did you mean: 

PoE failed and i am not able to power on the r510

New Contributor







I am needing help replacing the ICX7150-C12p. This is the second one that stopped working, I ha e tried multiple steps on fixing it from ports, to hard reset and it's still not working, I need approval from tech so I can provide the link to start my RMA process. 






























































































Please follow the below steps to check the whether your switch is powering on or not.

  1. Connect the computer to the ISP router with the ethernet cable. Run the speed test, and confirm if your speed is stable and search for websites,  make sure you have no issues.
  2. On your switch while it's plugged into the outlet, do you see any lights on? (Amber or green) Please let us know which lights are on? 


3- Make sure it is plugged into a well-known outlet/power source

4- Are the Access Points R510 powering up? 

5- Are you having any connectivity issues like webpage not loading or slow connectivity.

Also please provide an image/photo where you are trying to connect via console from ICX 7150 - C12 P (USB type C to  USB ) to PC. Before uploading the photos please login to the RUCKUS account and you can upload the image.



Best regards,


Lennar Home Community

Hi, was not successful with getting internet from ICX7150, please see the answers to the questions from above and adding the screenshot below 

1. pugged it in to the ICX7150 and got no internet, tried multiple ports did not work.

2. Figure 1. Port-side LEDs of ICX 7150-C12P- only two lights are on 

  1. System Status LED #7  -- Yellow
  2. Power status LED  #16-- Green

3. plugged in to a PowerSurge protector 

4. Access Points R510 are not powering up

5. non internet. screenshot below

Screenshot 2023-01-11 174619 no internet.png


Basically if the switch has one green and one yellow light, it means that the switch is stuck in boot mode.

1-Please try to disconnect from the Power outlet the ICX-7150 and reconnect it.

2-Please try to press the reset button using a paper click or a small stick 

  1. Remove power from the switch.
  2. Press and hold the Reset button while applying power to the switch.
  3. After all the system LEDs flash amber, release the Reset button.

Video link:

If this step doesn't work, we need to perform a software recovery.

Here is the quick guide to perform software recovery.

How to perform a Software recovery on an ICX7150 switch

Ruckus ICX Recovery Load boot code from boot monitor

Note: after fixing the issue of the Switch been stuck in boot mode, please perform an upgrade to the code 08095g UFI and upgrade both partitions with the switching code file named SPS08095gufi.bin, so perform the software recovery using the code 08090k with the upgrade image file named SPS08090k.bin, then when the switch is back to normal upgrade to the file SPS08095gufi.bin for both partitions primary and secondary.

1.Upgrade a Switch ICX-7150-C12P using a USB flash drive

  1. Upgrade a Switch ICX7150-C12P via TFTP

  1. Upgrade a switch via Web GUI (ICX7150 Switch)


Best regards,


Lennar Home Community


I tried all the steps, and nothing has been working i was able to download the required apps to make it works and nothing. i tried the recovery but it always gets stuck on the putty 3 minutes in. also tried to the hard reset but yet i don't get it to communicate. i have been at it for 4 hours and no luck ,i have use all the ruckus videos and it do not want to work. any other ideas? i followed the steps 1 by one what else could it be?