Showing results for 
Search instead for 
Did you mean: 

No power to AP

New Contributor
  • I have a ruckus switch ICX 7150-C12P. The power went out and rebooted it. I am now left with the switch having a lit up amber light on syst and a green on power. I have tried repowering the modem and the switch itself. I have also reseated all cat 5 cables to and from the switch and the AP’s. The AP’s currently have no power since the switch is POE. Does anyone have a solution to get the switch to resend out internet signal to the AP’s?



It seems that you have to perform a software recovery.


*The Switch will not provide power to any PoE devices (Doorbell, cameras, even the Access Points).

*Will not have connectivity to the devices connected to the Switch.

*The ISP router will work fine.

*Console access will be the only access available.

*System light will be yellow/orange/Amber.

Please follow the link below to be able to recover your switch:

How to perform a Software recovery on an ICX7150 switch


I've tried this and no luck.  

Hi @AmandaO 

Please provide an image where you are trying to connect via console.   ICX 7150 - C12 P (USB type C to  USB ) PC .

upload photo.png

Best Regards 

Fernando Vasquez