Showing results for 
Search instead for 
Did you mean: 

Need DHCP enabled

New Contributor


When my brother moved into a Lennar home his Ruckus system wasn't allowing connected wired or wireless users to the internet. I discovered nothing was issuing DHCP addresses so we connected an old Apple AirPort Express he had between the Ruckus router and the cable modem and everything came online. So Arris Cable Modem -> AirPort Express -> Ruckus (all via ethernet cables).

Equipment info:

ICX 7150-C12P Router
R510 x2 WAPs
Arris Cable Modem

There was some other issues with the setup even after it starting working so he eventually reached Ruckus telephone support and for whatever reason the support person either didn't notice the AirPort Express was acting as the DHCP server instead of the Ruckus equipment or didn't care, but this setup has remained for awhile now.

I'm visiting in person so I thought this would be a great time to remove the AirPort from the network topology since it's quite old and likely reducing his throughput to the internet. A quick poke around the admin GUI for the Ruckus router and I discovered the "Gateway Mode" checkbox was unchecked in Admin & Services -> System -> IP Settings

When I check the box, I set the "WAN PORT" to 1 since that is where the ethernet cable from the cable modem is plugged into. I left everything else to the default entries (if my brother uses all 2,000 IPs it makes available to hand out, we're going to have a talk). I left the WAN IP address set to DHCP since the cable modem hands out a single real-world IP. 

I hit apply settings and nothing seemed to happen after several minutes. I powered down the Ruckus router and the cable modem, turned on the cable modem first since that's been important in the past at times, once it was booted up I fired up the Ruckus router. Nothing worked at all. I connected my laptop to the Ruckus router via ethernet and although the status lights were all on for each ethernet cable plugged in (that had a device), I was not getting an IP address issued to my laptop. I tried manually setting my laptop's IPv4 to match the DHCP network the Ruckus was supposed to be handing out, but I still couldn't ping anything, including the Ruckus router. One of the two AP starting broadcasting a weird name that it was not connected to something it wanted (the Ruckus router probably?) and no matter what I did, I could not get connected to anything.

After reconnecting everything back the way it was and another reboot of the Ruckus router it thankfully starting pulling an IP address from the little AirPort Express again and the two APs seem happy once again as well. I'm again able to access the GUI and everything appears to be normal.

So before I blow everything up again, how can I have the Ruckus router start handing out DHCP addresses so that I can remove the old AirPort Express and plug the Ruckus directly into the cable modem?

Thanks all in advance.



Hi @Jerad 

The ICX7150 is not a router, is a Switch, however does have some routing capabilities including run a DHCP server, now the main issue here is that do not have NAT so will be uncapable to translate the Private IP address into the Cable Modem Public IP address, final the Access points does also have the capability to run as DHCP server and enable the gateway mode, but still the same, the cable modem does not have NAT as part of the features, this is why for Lennar home client you required a regular router connected between your ISP modem and the ICX7150 Switch.


*Access Point guide:

Configuring Gateway Mode


DHCP Server

*ICX7150 DHCP server set up:

Configuring the DHCP server and creating an address pool


Most common Setups for Lennar homes users



Best regards,

Yarenis Hernández.

Technical Support Engineer | L2 TAC Wired | Lennar Home Community