Showing results for 
Search instead for 
Did you mean: 

Icx7150 switch won’t reboot after power outage

New Contributor

Tried everything I found on the portal but I don’t have a computer degree so I still can’t get it running. Need to see if there is another option to get this back or at the very least reset to factory defaults. Tried the the reset button option but the light have been flashing amber for hours and still nothing. Need help please


RUCKUS Team Member

Hi Jcortez5501 

Thank you for reaching out to us. I see that you have also posted in "Ruckus Forums " -> "ICX" 

Link :

Are you able to access the switch using console ? 

I have attached a link below for reference . Please run through and try to check if you are able to access the switch using console. (If not please upload the pic of the error you are seeing when you access switch using console or share picture of LED indication in front panel of the switch )

Link :

YouTube Video :

Please login to the RUCKUS account and you can also upload the image as shown in below picture which can help us understand the issue better.



I am not tech savvy enough to understand anything in the video or pdf unfortunately that is completely above my head or level of knowledge expertise. I attempted the direction but I still don’t link to switch.( honesty don’t think I did it right) I have an amber system light and solid green power light in the switch but it is not powering any access points and anything connected to the switch has no internet. I really need to speak with someone to walk me through this. Step by step


Hi @jcortez5501 

Thank you for the response and the information you shared.

As we can see from the picture you shared there is an amber/orange light on the "SYST" and a green light on the "PWR" on the Switch. Meaning the Switch is stuck in the boot mode.

Basically, due to the power outage/ power spike, the switch went to a state that we call ‘boot mode’ that is not able to boot up properly. 

Please follow the below steps in order to fix this issue:

First, we will try to reset the Switch as described below:

1. Please try to disconnect from the Power outlet the ICX-7150 and reconnect.

2. Please try to press the reset button using a paper click or a small stick 

  • Remove power from the switch.
  • Press and hold the Reset button while applying power to the switch.
  • After all the system LEDs flash amber, release the Reset button.

Below is the Guide and Videos link for your reference:

Video link:


IF RESET DOESN’T WORK: Please follow the below steps.

If the reset does not make any difference, we need to perform a software recovery since it can be that the image flash is corrupted in basic words the unit is not able to boot up properly and need re-install the image to boot up properly.

Below is the Guide and Video Link to perform the Software recovery process:

Please refer to the below guide and Video link:

Video Link:

Please let us know once you finish this process. So that we could assist you in upgrading your Switch to the latest stable version to avoid these issues in the future.

Please let me know if you have any queries in this regard.

Thank you again for your patience and understanding.


Best regards,

Imran Sanadi

Lennar Home Community.