Showing results for 
Search instead for 
Did you mean: 

ICX7150-C12P-2X1G not Powering up at all

New Contributor II

I have a Lennar home which has ICX7150-C12P-2X1G.  My switch is not powering up. I tried clicking the "status" button and nothing shows up. Upon reading on this forum, I understand that there are other users who had similar issue and these devices have lifetime warranty. 

Can someone please assist me with this issue? PXL_20240606_023931611.jpgPXL_20240606_023937925.jpg


Hi @Gaurav 

Greetings of the day!!!

Thank you for sharing the requested PICTURES and a VIDEO.

Based on the troubleshooting done, your ICX-7150-C12P Switch is not powering up, and when plugged in, it flashes an amber light and then goes dark. And you confirm that the Switch is plugged into a well-known outlet/power source. However, the failure persists. This Switch unit Should be RMA (Return Merchandise Authorization) in simple words replacing it.

Feel free to contact us via chat, comment you already have a post, copy the link from the post (URL), and paste it into the chat to start the unit replacement.

Please follow the steps as shown in the below example:

As shown in the below picture, copy the link and share it via chat from the link provided:

The below link is to contact us by chat (only)

Did I answer your queries? If yes, hit the Kudos buttons and also accept the answers as Accepted solutions.

Please let me know if you have any queries in this regard.

Thank you again for your patience and understanding.


Best regards,

Imran Sanadi

RUCKUS Lennar Home Community.

View solution in original post



Hi @Gaurav 


Thank you for reaching out to RUCKUS Lennar Home Community. 

I trust this message finds you well.

We appreciate the information provided. Based on the details shared, it appears that your RUCKUS ICX-7150-C12P Switch is experiencing power issues.

To address this concern, we recommend attempting a hard reset of the switch multiple times, following the steps outlined in the RUCKUS Lennar Knowledge Base self-help article available at the following link:

Please follow the instructions provided in the article and inform us of any developments regarding the switch's power status.

Thank you for your cooperation and patience throughout this process.


Best regards,

Imran Sanadi
RUCKUS Lennar Home Community

New Contributor II

Hi Imran,

Thanks for your response.

I tried hard resetting based on the article you sent multiple times, however, the lights appear for 1 second as I put the power back into the switch and then nothing happens. No lights starts blinking, no sign of restart or reset or even boot up.

Hello @Gaurav 


Thank you for your prompt response and the detailed instructions provided.

To proceed with resolving the issue with your ICX-7150-C12P Switch, we kindly request that you follow the steps outlined below:

1. Plug your ICX-7150-C12P Switch into a functioning power outlet.

2. Capture both pictures and a video of the switch, focusing on the following:

   - The status of the lights on the switch.

   - The cord connected to the switch.

   - The switch plugged into a working power outlet.

We recommend referring to the example pictures provided below to ensure clarity in capturing the required details:

Additionally, please use the provided link to upload a video. We advise referencing the EXAMPLE VIDEO in the Google Drive link provided to ensure consistency in the recording:

Should you have any queries or require further assistance, please do not hesitate to reach out. We are here to help.

Thank you for your cooperation, patience, and understanding as we work to resolve this matter promptly.


Best regards,

Imran Sanadi

RUCKUS Lennar Home Community

New Contributor II

Hi Imran,

Thank you for your prompt response.

I have uploaded my video in the same folder as referenced above. Here is the direct link:


Thank you,

Gaurav Kumbhat