Showing results for 
Search instead for 
Did you mean: 

ICX disconnected from Unleashed; connectivity issues between AP and ICX

New Contributor II

Like everyone else here I have a Lennar-provided ICX 7150 and two APs. Something happened over the weekend and the ICX started showing up as Disconnected in the Unleashed GUI. Symptomatically things were 'connected', but traffic through the ICX to our ISP's stupid combo modem/router was having lots of issues.

I searched around on these forums (before finding the Lennar-specific section) and found some people with similar problems getting an ICX to connect to Unleashed. I tried factory resetting the ICX and re-adding it, but that didn't work. The ICX shows up in Unleashed as Pending, then prompts to enter the IP to join it (Auto Approve is enabled but seems like the ICX is in 'Router' mode per the docs?).

No matter what I have tried, after approving the ICX, it tries connecting and then shows up as Disconnected with a message that the ICX could not be pinged. 

I also updated the ICX to 08.0.90f via TFTP, but the result was the same.

I verified that LLDP is fine between the ICX and APs, but ICMP is not. I indeed can't ping the ICX from the AP, but I can ping it when I'm on the wired network from the ISP router. Interestingly when I'm connected to the router, I can't ping the AP directly. I can ping the AP if I'm on the wifi network being broadcast by Unleashed, but then I can't ping the ICX.

I know that was pretty hand-wavy but I can clarify if needed. 


Community Admin
Community Admin

Hi Jacob,

In a recent case, it was turned out the Ruckus switch booted into router mode. Customer had a brief power outage.

We booted it into switch mode and everything got stable! We also replaced the router image file with the switch image file so it won't go into the router mode in the future.

Check if if you hitting the same issue.

Syamantak Omer | Sr.Staff TSE | CWNA | CCNA | RASZA | RICXI

View solution in original post



I want to run the 7150 in router mode, is it possible to create or maintain an unleashed GUI connection while booting the ICX router firmware?

Hi Harold,

If you want to see it as router code, you have to make sure it is correctly placed in the network setup because it is no longer a switch but a router.

As long as Unleashed is able to communicate with SW, it should be able to manage the switch.

On a side note, SW booting up with router image and causing issues has nothing to do with Unleashed but difference between how the traffic routing is done on a router vs switch.

Syamantak Omer | Sr.Staff TSE | CWNA | CCNA | RASZA | RICXI

New Contributor II

This sounds promising!

So I can tell that I did indeed flash the Router image, I just used the manifest file as described in the docs not realizing there was a whole other SPS image there. 

If it's possible that the switch incorrectly restarted in 'Router' mode, does that imply that there's a way to force it to start up in 'Switch' mode? Or do I have to reflash it (not a big deal if so).

I'm having a hard time finding the commands in either case, though; could you point me to how to get the manifest to point to the SPS image, or how to modify the config to force it to act as a switch?

Nevermind; I am just going to flash the SPS image and see what happens.


Hi Jacob,

To check the flash.

show flash

To boot from primary or secondary.

boot system flash primary


boot system flash secondary

Note: Use the global configuration mode to set the boot preference permanently. Doing it from enable mode will be effecting only once and may revert to different image upon next reboot.

Syamantak Omer | Sr.Staff TSE | CWNA | CCNA | RASZA | RICXI


Do I need to connect laptop to switch using c-cable and do the terminal to run above commands?

I am also facing this issue. My ICX showing disconnected. The internet working fine in windows and android phones but not in iphone and macbook or ipad. 

Anyone has any idea ?

Here is the image

Image_ images_messages_60dc7c66015f4c5c8d50c5f3_5479daadb4c8884a3c754965a1fe5d29_tempsnip-87a11173-2a06-445e-9bd4-72a3ada4d161-980519633.png