Showing results for 
Search instead for 
Did you mean: 

ICX 7150-C12p not powering r510s

New Contributor

The PoE has failed for my ICX switch box. I've tried restarting the box, powering it down, replacing the r510s, and etc. However, the same problem persists. I have the yellow system light on, and I can't connect to my access points.


Hi @BusyReading 


Thank you for contacting Lennar Home Community.

Hope you are doing well!!!

As per the case description, I could understand that your RUCKUS R510 Access Points are not powering up. 

As you mentioned, there is an Yellow light on the SYST,

If there is an amber/orange light on the "SYST" and a green light on the "PWR" on the Switch (As in the below picture). Meaning the Switch is stuck in the boot mode.

Basically, due to the power outage/ power spike, the switch went to a state that we call ‘boot mode’ that is not able to boot up properly. 

Please follow the below steps to fix this issue:

First, we will try to reset the Switch as described below:

1. Please try to disconnect from the Power outlet the ICX-7150 and reconnect.

2. Please try to press the reset button using a paper click or a small stick 

  • Remove power from the switch.
  • Press and hold the Reset button while applying power to the switch.
  • After all the system LEDs flash amber, release the Reset button.

Below is the Guide and Videos link for your reference:

Video link:


IF RESET DOESN’T WORK: Please follow the below steps.

If the reset does not make any difference, we need to perform a software recovery since it can be that the image flash is corrupted in basic words the unit is not able to boot up properly and need re-install the image to boot up properly.

Below is the Guide and Video Link to perform the Software recovery process:

Please refer to the below guide and Video link:

Video Link:

Please let me know if you have any queries in this regard.

Thank you again for your patience.


Best regards,

Imran Sanadi

Lennar Home Community.

I kept on retrying the reset to see if I could revive the swtich, and it worked after the 4th time. Thanks for the help 🙏

Nevermind it went back to the amber system light.

Hi @BusyReading 


Thank you for contacting RUCKUS Lennar Home Community.

Hope you are doing well!!!

Thank you for the information you shared.

Apologies for the inconvenience. 

Could you please try to reset the Switch again as described previously? And once it is reset, we can Upgrade your Switch to the Latest stable version to avoid this issue in the future.

Please let me know if you have any queries in this regard.

Thank you again for your patience and understanding.


Best regards,

Imran Sanadi

RUCKUS Lennar Home Community.

Can you download putty to your computer that way you can access the CLI. You will want to run this command "inline power" but you will need to change it to the interface that the access point is connected to. Here are the commands you will need to run in order without the quotation marks.

1. "config t"

2. "interface ethernet 1/1/5" or the port your access point is connected to

3. "power inline"