Showing results for 
Search instead for 
Did you mean: 

ICX 7150-C12p not powering r510s

New Contributor

The PoE has failed for my ICX switch box. I've tried restarting the box, powering it down, replacing the r510s, and etc. However, the same problem persists. I have the yellow system light on, and I can't connect to my access points.


RUCKUS Team Member


Thank you for reaching us.

Please let us know where exactly is the yellow/amber light is being observed by you.

If its switch, Syst LED is yellow/ amber, might be device is booting up or has stopped at the booting stage.

Could you, please confirm if device is stuck at the boot stage and have console access to ICX unit.

If it is stuck then please find the below link for a software recovery process.

Moving Forward If this issue still not resolved , Please log a ticket with the below link so that we will help you to proceed further.

I hope this information helps you

Please feel free to leave us a message if any concerns.

The url you linked leads me to a 404 page unfortunately.

I'm going to be completely honest with you. I have no idea how to do any of this. These steps have the assumption I know what half of these commands and hardware parts are. I don't even know how to get to a terminal for this switch.

Look I'm from the Lennar side, can I just get a replacement? I never even set up a server for this at all. It's just a switch to extend my ethernet ports.