Showing results for 
Search instead for 
Did you mean: 

ICX 7150 C12P no power

New Contributor

I have a ICX 7150-C12P that stopped working in the middle of the day and will not power on. I have tried to reset it multiple times but the lights dont come on at all. I have tried to connect it directly to my Mac where I was able to download and install the serial drivers but the device will not respond to terminal commands. 

Lights pop on for a quick moment then nothing... 

I think I need to RMA this device. I tried to start that with the chat "fetch" service but not sure that was done properly. Any additional service/support would be greatly appreciated. 


Thank you , 

Andrew Filson


RUCKUS Team Member

Hi AndrewFilson

Thank you for reaching us. 

  • Could you please let us know if you are from Lennar Homes ?

Could you please help us with the below queries to assist you better?

1. Was there any power outage before you started facing this issue?

2. On your switch while it's plugged into the outlet, do you see any lights on? (Amber or green) Please let us know which lights are on. (Please refer to the below picture and share a picture of the same, showing the light status and the FULL Switch panel cable connections to the Switch ports)


3. Is your Internet Connection from the Internet Service Provider (ISP) stable and working? (You could check this by connecting to your local router Wi-Fi or from an ethernet cable from Router to a laptop/PC).

4. May I know how many Access Points are connected to the Switch? Could you please let me know the light status on the Access Points? Any of these lights are on (Please refer to the below picture and share a picture of the same)



Please help us with pictures of your ICX-7150-C12P Switch showing the status of the lights and cable connections to the Switch ports. Also, light the status of Access Points.

Before uploading the photos please log in to the RUCKUS account and you can upload the image.



Yes I am a Lennar customer.

1. There was no power outage. Kids were watching a movie and internet went out but when I checked the internet was fine it was just the switch that appeared to have lost power. I changed the power cable and reset the device no effect.

2. When first plugged in the lights next to the status button are green for a fraction of a second. Thats the only sign of activity on the device. 

3. Yes the internet is working I have a wired connection that works and setup a replacement wifi router in its place for now so the cable works and internet works.

4. There are three access points in the home and none of the lights come on atm. 

There are no lights on anything save for that split second when it is first plugged in. 

Hope this helps. 


Hi @AndrewFilson

Please plug your ICX-7150-C12P switch into a power outlet and send us a picture and video of the switch showing the light status and the power cord as mentioned below.


Please use the below link to upload the video.






Please let us know if you have any queries in this regard.



Best regards,


Lennar Home Community

here is a picture of the device plugged in. I will upload the video of it being plugged in once access has been granted to that Google Drive folder.