Showing results for 
Search instead for 
Did you mean: 

I need Warranty support after Ruckus ICX 7150 has suffered a hardware failure.

New Contributor

Lennar Home. My ICX 7150 has failed. Probably due to the power outage. I need a new one. I tried to file a claim.  After entering all the information I received an automated response that my serial # is not registered.  Is there a way to speak with a human?   




Hi @Reospark

Note:We do not have email, phone or remote access support, Lennar customers only receive support through the community forums, Please read the guides carefully before start the troubleshooting.

1:is the Switch no longer powering up, if that is the case, please ensure that the issue is not the power outlet.

2:If your switch have the next symptoms, please follow up the next guide.

The Switch will not provide power to any PoE device.

Will not be any connectivity to the devices connected to the Switch.

The ISP router will work fine.

Console access will be the only access available.

System light yellow/orange


1:How to console in the ICX-7150-12CP 'Ruckus Switch'

RUCKUS ICX 7150 USB TYPE C CONSOLE (tutorial video)

2:How to perform a Software recovery on an ICX7150 switch



New Contributor

One of my expert neighbors, who is a configuration architect, came over and plugged into it and confirmed the hardware is shot. I need a new Ruckus. Is there a way to find out if I have any warranty coverage?


Hi @Reospark 

Hope you are doing great ! 

We can't confirm if it's a hardware or software failure without doing some troubleshooting.

Without this information we cannot proceed with a unit replacement either.

1-Could you please indicate which color is the system light ? '7'


2-If the unit is not powering up at all ( no lights at all ) have you tried another power cord/power outlet ? 

Best regards 

Fernando Vasquez 

Hi Vasquez

I do not know what happen to my last reply.

But this is what I said.  There are no lights on Ruckus device. There is nothing I can check on the device. It is dead.  the power source/receptacle is good. It has 120 vac. I did utilize another receptacle to make sure. The Ruckus still did not power up.  

Because the unit hardware has failed I cannot run diagnostics.

Please advise where I go from here. How do I resolve this problem?