Showing results for 
Search instead for 
Did you mean: 

Failed Switch - Stuck in crash mode

New Contributor

Apologies as I do not have any experience with switches so please bear with me. I recently had a power outage and now my ICX7150 C12p is stuck in boot mode however, when I try to factory reset the lights keep blinking amber.  I tried to do the software recovery but I cannot connect to the switch.  The serial cable is not found. The only thing I see is Bluetooth over serial. I believe I may need to RMA this device.  Is this something support can help with?  Thank you! 



Hi @rleschber 


Thank you for contacting Lennar Home Community.

Hope you are doing well!!!

As per the case description, I could understand that your RUCKUS ICX-7150-C12P Switch is stuck in boot mode.

Once again, please try to reset the Switch as described below:

1. Please try to disconnect from the Power outlet the ICX-7150 and reconnect.

2. Please try to press the reset button using a paper click or a small stick 

  • Remove power from the switch.
  • Press and hold the Reset button while applying power to the switch.
  • After all the system LEDs flash amber, release the Reset button.

Below is the Guide and Videos link for your reference:

Video link:


IF RESET DOESN’T WORK: Please follow the below steps.

If the reset does not make any difference, we need to perform a software recovery since it can be that the image flash is corrupted in basic words the unit is not able to boot up properly and need re-install the image to boot up properly.

Below is the Guide and Video Link to perform the Software recovery process:

Please refer to the below guide and Video link:

Video Link:

As you tried the Software recovery process, could you please share the screenshot of the error you are getting? or please let us know at what step of the process you are stuck on.

Please let me know if you have any queries in this regard.

Thank you again for your patience and understanding. 


Best regards,

Imran Sanadi

Lennar Home Community.