Showing results for 
Search instead for 
Did you mean: 

Dead ICX 7150-C12P

New Contributor

Hello support team, I am Lennar home owner with a ruckus IXC 7150-c12p and a WAP. My unit will not stay powered on. When the power is cycled, the amber lights flashes then nothing. I've tried everything suggested on this forum with the same results. What do I need to do to get an RMA replacement?



Hi @crlloyd1965

Thank you for contacting Lennar Home Community.

Hope you are doing well!!!

Thank you for the information you shared,

As per the case description, I could understand that your ICX-7150-C12P Switch has a Amber lights flashing.

Could you please let us know?

  1. For how long have you been facing this issue? And was there any Power Outage?
  2. On your switch while it's plugged into the outlet, please let us know which lights are on. (Please refer to the below picture)

Please help us with pictures of your ICX-7150-C12P Switch showing the status of the lights. 

Please let me know if you have any queries in this regard.

Thank you again for your patience.


Best regards,

Imran Sanadi

Lennar Home Community.

There was no power outage. The amber lights only flash on momentarily when power is applied then immediately go out. This started early Friday morning. 

Hi @crlloyd1965

Thank you for the response and the information.

As your ICX-7150-C12P Switch is not powering up, we will try to reset the Switch first:

Please follow the below steps in order to fix this issue:

First, we will try to reset the Switch as described below:

1. Please try to disconnect from the Power outlet the ICX-7150 and reconnected.

2. Please try to press the reset button using a paper click or a small stick 

  • Remove power from the switch.
  • Press and hold the Reset button while applying power to the switch.
  • After all the system LEDs flash amber, release the Reset button.

Below is the Guide and Videos link for your reference:

Video link:


IF RESET DOESN’T WORK: Please follow the below software recovery steps.

If the reset does not make any difference, we need to perform a software recovery since it can be that the image flash is corrupted in basic words the unit is not able to boot up properly and need re-install the image to boot up properly.

3. We must get console access to the ICX-7150-C12P Switch as mentioned in the steps from the guide below:

How to console in the ICX-7150-C12P:

Below are the Guide and Video Link to perform the Software recovery process:

Please refer to the below guide and Video link:

Video Link:


Please let me know if you have any queries in this regard.

Thank you again for your patience.


Best regards,

Imran Sanadi

Lennar Home Community.

The reset does not work, I've tried this multiple times. I've read the suggested material and watched the video but I do not understand how I can connect and console this unit to do a software recovery when there is no power on the unit at all. Am I missing something? I'm have a technical background.