Showing results for 
Search instead for 
Did you mean: 

Check firmware version and update ICX7150-C12P?

New Contributor

Hello - I purchased my Lennar home in April 2020, and have an ICX7150-C12P switch that recently wasn't booting and I needed to reset. It seems to be working now, but when I was reading various forums trying to troubleshoot, I did notice recommendations to update firmware on the switch.

When my switch finally restarted after the rest, I was able to use the Unleashed app to check and update firmware but I think that's only for the R510 access points? When I attempt to login to the switch by going to its IP address in my web browser and using what I thought was the correct login and password, it's not working. 

Should this login (directly to the switch's IP address) use the same credentials as used in the Unleashed app? If not, how would I find out what the correct login info is? (I thought perhaps due to the reset the login reverted to the original provided by Lennar, but that didn't work either). 

Alternatively, is there another way to see which firmware version is on my switch and update it, without needing a cable (which the installer didn't leave here) or messing around with a command-line? Thanks


New Contributor

Hello Yarenis,

Thank you for your previous help. After some delay I attempted to upgrade my switch to the latest version according to your instructions. I originally planned to use a thumb drive with the file SPS08095gufi.bin on it, following the directions here: 

However, when I looked more closely at your instructions, I interpreted them as connecting to the software server directly by tftp to get the SPS08095gufi.bin, so I didn't need the thumb drive. 

My first step I believed was to console into the switch using a cable, as I had done before. I attempted the same commands as before:

In Mac Terminal, ls /dev/cu.*, then screen /dev/cu.SLABS_USBtoUART to get a command line on the switch which should have looked as ICX7150-Boot> like before. However, this time the screen /dev....etc. command did not lead to a command line on the switch, and instead asked for a login and password.

I tried to use the login and password from my Unleashed app, which didn't work. I tried all the standard login combinations here but none worked. I had previously written all changed passwords on the startup documentation left at the house when I moved in, but didn't record any separate login for the switch vs the Wireless Access Points/unleashed app. I'm also not quite sure why it's asking for the login/password now when it didn't before, but can you help me work around this, or clarify if using console access is what I'm supposed to do? 

If not console, can you clarify what method to use to get to the point where I can use the commands you suggested in your instructions, starting with device# copy tftp flash SPS08095gufi.bin primary?

Thank you. 


hat before I could use the commands you listed (starting from "device# copy tftp flash SPS08095gufi.bin primary

Hi @ AK

You can upgrade the Switch either via TFTP or with the thumb drive, if the Switch is showing in the Unleashed Dashboard you can also upgrade from the unleashed, from there the only you required is the image SPS08095gufi.bin, so let me add the guide to upgrade with the Unleashed dashboard in case the Switch is showing, or with the thumb drive, now as you mentioned you can gain access to the switch via Console, SSH or telnet, but if it is asking for credential, and you have tried all the combination for the ICX, you will need to perform a password recovered, but unfortunately to perform the password recovered will be necessary to gain console access, now I will advise try first the upgrade of the Switch via Unleashed Dashboard.

1:Gain access to the Unleashed Dashboard using the IP address of the master access point, like you have access to the APP you can find the IP address of the master Access Point, so copy and paste in a web browser.

2:Once you are connected to the Unleashed dashboard, try to check if the Switch is showing.

Expand the Switches>if you see the Switch as connected you will be able to upgrade from there, the only you will require will be downloaded the code 08095g and find the image SPS08095gufi.bin

Upgrading ICX Switch Firmware

3:If the Switch is not showing, try to gain access via Console, SSH, or telnet to the Switch and try the next combination of credentials, including the same credential you used for your own access to the Unleashed APP.

Usernames:           Passwords:

admin                    sp-admin

super                     Lennar







4:If the credentials still no working, try the password recovery, but you're required to be connected via console access to the Switch.

Password Recovery on a Ruckus ICX(Tutorial video) from a lost password (CommScope Guide)

5:Once you gain access to the Switch, you can perform the upgrade to the code SPS08095gufi.bin using the thumb drive, take in consideration that if you are running a code 08080 or higer will be matter to upgrade bot partitions to the code SPS08095gufi.bin


ICX7150-C12 Switch#copy disk0 flash  SPS08095gufi.bin primary

ICX7150-C12 Switch#copy disk0 flash  SPS08095gufi.bin secondary

ICX7150-C12 Switch#write memory

ICX7150-C12 Switch#boot system flash primary yes

How to Upgrade a Switch ICX-7150-C12P using a USB flash drive

Best regards,

Yarenis Hernández.

Technical Support Engineer | L2 TAC Wired | Lennar Home Community Moderator

New Contributor

i unfortunately haven't been successful with manually updating any Ruckus switch's.
What i have noticed is that these switches don't like to save the settings within them. 
Log into your ruckus switch using the IP of the switch with /Home at the end and then log in using the provided username/password provided by Lennar. (Username is usually Lennar but you can change or add user accounts).
Check the time on the switch. if it is not current time and date, change it, apply settings and then on the left at the bottom click save config... 
This will correct the time sync and should work better. Also make sure the switch is in Switch Mode and not Router Mode.