Showing results for 
Search instead for 
Did you mean: 

Certain Devices Don't Have Internet

New Contributor

Hello, I have four r510 access points in my house. Since a couple of days ago, the WiFi pretty much just stop working for my phone, the Amazon Alexa devices, it's either completely no internet, or there's a lag of 30 seconds or a minute until my phone/Alexa devices would respond. Also, note that my phone would have a pretty normal connection right after I connect the WiFi (I switch the WiFi off on my phone then switch it back on), and after about 10 seconds or so the WiFi on my phone would when back to no internet or ultra slow. My laptop, however, is doing completely fine, with no lag, good speed. I have turned off the entire system a couple of times and did a factory reset. I reconnect the cables between the controller and the access points but none of those solve the problem. After I tried all the methods I mentioned to fix the issue, I still couldn't think of any cause of this, so any help is appreciated!



Hi Dewei,

Could you confirm if its a Lennar home and you have an ICX switch as well?

If yes, most probably switch bootup image has changed from switch code to router code and causing these issue.

In order to fix this, you have to boot the switch again from switch code.

Syamantak Omer | Community moderator | Sr.Staff TSE | CWNA | CCNA | RASZA | RICXI


Hello Syamantak,

Indeed it is a Lennar home (the Village Builder), but I have fixed the problem last night by shutting down the whole system for about 20 minutes. I guess the reboot worked after I did the factory reset, so no worries and thank you for responding!

@dewei_lin​ good to know that you were able to fix the issue. However, if switch still has different codes in its primary and secondary flash, problem can persist in future.

Just SSH into the AP and run below command and share the output.

show flash

show version

Syamantak Omer | Community moderator | Sr.Staff TSE | CWNA | CCNA | RASZA | RICXI