Showing results for 
Search instead for 
Did you mean: 

Cannot get COM port when connecting to the switch

New Contributor

My ICX 7150-C12P seems to be stuck in boot mode (amber system light). When I connect to the switch via port 15 I am not seeing a com port in my device manager. When I connect to port 13, I get a green light on my adapter and the switch port (so I know the cable and connections on both ends are good). I even tried using MobaXterm to get it to automatically recognize the COM port, but it is coming up empty. 

I am on Windows 10 Pro. I turned off Windows defender to check to see if that was limiting the connectivity. What else do I need to check so that i can get the switch to boot, and/or do a software recovery? 

Thanks in advance for your help. 



Hey @krugenator 

Are you a Lennar customer? Console port on your unit should be USB type C. It will not be one of the dataports. 


Ben Beck, RCNA, RCNI, Principal Technical Support Engineer

New Contributor

Ben - 

yes it is a Lennar unit. the instructions on the specify you can connect to port 1 (USB Type C) or port 15 ethernet depending on the cable you have (it also said if you have to do a software recovery that is done via port 13 which is just ethernet (RJ45 I guess)). I ordered a USB ethernet adapter for this.

I tried to connect my laptop USB type C (port on my laptop) to USB type C (switch) as well before ordering the cable but no luck. Is there a way to chat with someone to work through this?

Hi @krugenator 

These cables in the guides are exclusive to access the console on the ICX-7150 C12P 'USB to USB type C' and 'Rj45 to USB', when using adapters we do not guarantee that this connection can be achieved.

I know some customers create a connection like this : 

USBC cable -->female USBC to male USB3.1 --> female USB3.0 to male USBC.

But the most important part is to install the software so the PC or Workstation can read the cable correctly 

Best Regards

Fernando Vasquez

Hi Fernando - 

Good news I have been able to establish connectivity between my laptop and the 7150 switch. I am attempting to do the software recovery. I have configured my ethernet adapter to be a static IP per the instructions (and verified via ipconfig). I have also set the env parameters on the switch and verified via printenv. 

The challenge I face now is that i cannot ping my laptop from the switch. Are there reasons why it might not be able to ping? Here is the printenv from my 7150 switch. Please advise

ver=10.1.15T225 (Jan 30 2019 - 23:08:47 -0800)