cancel
Showing results for 
Search instead for 
Did you mean: 

Ruckus Management

CiscotoRuckus
New Contributor II

New to the Ruckus Game.

Trying to get management working.  I would like to SSH to the device without using mgmt port.  Here is what I have, Cisco Router, single cable to Ruckus switch.  Router and switch are communicating, I get dhcp from the router but can't ping.

sh run
Current configuration:
!
ver 08.0.70dT231
!
stack unit 1
module 1 icx7650-48zp-port-management-module
module 3 icx7650-100g-2port-200g-module
!
vlan 1 name DEFAULT-VLAN by port
spanning-tree 802-1w
management-vlan
default-gateway 10.0.0.1 1
!
vlan 10 name DATA by port
tagged ethe 1/1/1
!
vlan 20 name VOICE by port
tagged ethe 1/1/1
untagged ethe 1/1/48
!
vlan 888 by port

!
aaa authentication login default local
!
hostname xlab-r10
ip address 10.0.0.2 255.255.255.0
!
!
interface ethernet 1/1/48
spanning-tree 802-1w admin-edge-port
stp-bpdu-guard

!
end

Cisco Router

interface GigabitEthernet0/0/0
description trunk to XLAB LAN
no ip address
negotiation auto
!
interface GigabitEthernet0/0/0.1
description XLAB LAN MGMT segment
encapsulation dot1Q 1 native
ip address 10.0.0.1 255.255.255.0
ip pim sparse-mode
!
interface GigabitEthernet0/0/0.10
description XLAB LAN DATA segment
encapsulation dot1Q 10
ip address 10.0.1.1 255.255.255.0
ip pim sparse-mode
!
interface GigabitEthernet0/0/0.20
description XLAB Voice LAN
encapsulation dot1Q 20
ip address 10.0.2.1 255.255.255.0
ip pim sparse-mode
no cdp enable

 

3 REPLIES 3

BenBeck
Moderator
Moderator

Since you have management vlan defined under the vlan, you will only be able to telnet/ssh within that vlan. If you come in on a different vlan it will be denied. Your other option is to just configure a normal routing interface (VE) and then you can manage it from inbound dataports. If you have not flipped on ssh, you will need to do that on this older code:

conf t

crypto key gen (tab for options if you want something specific)

 

Ben Beck, RCNA, Principal Technical Support Engineer
support.ruckuswireless.com/contact-us

Thank you for the reply.  I did read about VE interfaces.  My gear does not have that option?  Old OS?

xlab-r10(config)#interface
ethernet Ethernet port
lag Lag Interface
management Management ethernet port
xlab-r10(config)#interface ve
Unrecognized command

Chandini
Internal Employee

Hi Team 

Please check if your image is a router or a switch image . 

If router image then when you run "Show version" you will see " SPR " and if switch you will see " SPS"

The initial "SP" may vary based on models but "R" and "S" will help you understand if the firmware is "router " or "switch " firmware 

ve commands are not supported in switch firmware "S"

Also please refer firmware related release notes to check on any changes with commands for the firmware used in the switch. Thanks