Showing results for 
Search instead for 
Did you mean: 

ICX7150-C12P-2X1G not powering up

New Contributor

My switch does not power on anymore since yesterday. When power cord is inserted, all lights blink once and then there is no power anymore. I also cannot connect via USB to the computer. I think my device needs to be replaced. Thank you. Please let me know if anyone has any suggestions. I open case last time too, I got lots of suggestions from lots of friends. Most of them said used different power cord and different power out let I did all of that but not problem solved. I still having a problem. Some reason my case was closed I really need replacement my device. Please need your help to fixed my issues. Again please anyone has any suggestions much appreciated. 
Thank you


RUCKUS Team Member

Hi @Nckharel 

I do understand that switch is not powering on from the post as well you tried different power cable and power outlet and still not working. 

Please log a ticket with the below link so that we will help you to process RMA

Note: Please feel free to mark the post as ACCEPTED SOLUTIONS if its addressed your query.


Kamlesh M